summaryrefslogtreecommitdiffstats
path: root/testing/greybird-themes
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-05 14:40:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-05 14:40:31 +0000
commit77e3c0597e2a9f80c04c1734b17937baab2988e6 (patch)
tree4508b15b3d4e0dd5e9c3acecbd637269afefdf5b /testing/greybird-themes
parent3021541281d7aa49e7ae601c740819a60a045ef2 (diff)
downloadaports-77e3c0597e2a9f80c04c1734b17937baab2988e6.tar.bz2
aports-77e3c0597e2a9f80c04c1734b17937baab2988e6.tar.xz
testing/greybird-themes: new aport
A clean minimalistic theme for Xfce, GTK+ 2 and 3 http://shimmerproject.org/project/greybird/
Diffstat (limited to 'testing/greybird-themes')
-rw-r--r--testing/greybird-themes/APKBUILD73
1 files changed, 73 insertions, 0 deletions
diff --git a/testing/greybird-themes/APKBUILD b/testing/greybird-themes/APKBUILD
new file mode 100644
index 000000000..b3d6b8244
--- /dev/null
+++ b/testing/greybird-themes/APKBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=greybird-themes
+pkgver=1.4
+pkgrel=0
+pkgdesc="A clean minimalistic theme for Xfce, GTK+ 2 and 3"
+url="http://shimmerproject.org/project/greybird/"
+arch="noarch"
+license="GPLv2+ or CC-BY-SA"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-gtk2 $pkgname-gtk3 $pkgname-metacity $pkgname-xfwm4
+ $pkgname-xfce4-notifyd:_notify"
+source="greybird-$pkgver.tar.gz::https://github.com/shimmerproject/Greybird/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/Greybird-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ # Cleanup
+ # Remove Unity theme
+ rm -f gtk-3.0/apps/unity.css
+ rm -f gtk-3.0/apps/lightdm-unity-greeter.css
+
+ sed -i '/unity\.css/d' gtk-3.0/gtk.css
+ sed -i '/lightdm-unity-greeter\.css/d' gtk-3.0/gtk.css
+ sed -i '/lightdm-gtk-greeter\.css/d' gtk-3.0/gtk.css
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/share/themes/Greybird
+ cp -pr * "$pkgdir"/usr/share/themes/Greybird
+}
+
+_mv() {
+ pkgdesc="$1"
+ install_if="$pkgname=$pkgver-r$pkgrel $2";
+ depends=
+ local _i
+ shift; shift
+ mkdir -p "$subpkgdir"/usr/share/themes/Greybird
+ for _i; do
+ msg "moving $_i"
+ mv "$pkgdir"/usr/share/themes/Greybird/$_i \
+ "$subpkgdir"/usr/share/themes/Greybird || return 1
+ done
+}
+
+
+gtk2() {
+ _mv "Greybird GTK+2 themes" gtk+2.0 gtk-2.0
+ depends="gtk-murrine-engine"
+}
+
+gtk3() { _mv "Greybird GTK+3 themes" gtk+3.0 gtk-3.0; }
+metacity() { _mv "Greybird Metacity themes" metacity metacity-1; }
+xfwm4() { _mv "Greybird Xfce4 themes" xfwm4 xfwm4 xfwm4_compact; }
+_notify() { _mv "Greybird Xfce4-notifyd themes" xfce4-notifyd xfce-notify-4.0; }
+
+md5sums="da5345a9b253fd9bf5ea101a3ecc2fb5 greybird-1.4.tar.gz"
+sha256sums="e4d42de800d32ce4c7670afd546aa3ff37716e05fdff821a3d803b8d0603c571 greybird-1.4.tar.gz"
+sha512sums="8b414373f01655673e29c7454f88ffffade10b8a0883e777b1b5f41706042253d04ff5f886bb70a0e01a869f4ee5cb2dbe50dde4b48df5e4956d6446aaf16621 greybird-1.4.tar.gz"