summaryrefslogtreecommitdiffstats
path: root/testing/greybird-themes
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-10-17 06:18:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-17 06:18:09 +0000
commitb13d6899cabcbce9bb202da00ff29c8e641a3ebe (patch)
tree82ab01974503fc9f47702f6c86a4be53787abb3c /testing/greybird-themes
parenta2039cacbd8cf3a9f73e72b68b867f4bdcf3ecc3 (diff)
downloadaports-b13d6899cabcbce9bb202da00ff29c8e641a3ebe.tar.bz2
aports-b13d6899cabcbce9bb202da00ff29c8e641a3ebe.tar.xz
testing/greybird-themes: add fix for gtk-3.14
from https://github.com/shimmerproject/Greybird/issues/69
Diffstat (limited to 'testing/greybird-themes')
-rw-r--r--testing/greybird-themes/APKBUILD15
-rw-r--r--testing/greybird-themes/gtk-3.14-fix.patch17
2 files changed, 27 insertions, 5 deletions
diff --git a/testing/greybird-themes/APKBUILD b/testing/greybird-themes/APKBUILD
index b3d6b8244..735e08873 100644
--- a/testing/greybird-themes/APKBUILD
+++ b/testing/greybird-themes/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=greybird-themes
pkgver=1.4
-pkgrel=0
+pkgrel=1
pkgdesc="A clean minimalistic theme for Xfce, GTK+ 2 and 3"
url="http://shimmerproject.org/project/greybird/"
arch="noarch"
@@ -12,7 +12,9 @@ makedepends="$depends_dev"
install=""
subpackages="$pkgname-gtk2 $pkgname-gtk3 $pkgname-metacity $pkgname-xfwm4
$pkgname-xfce4-notifyd:_notify"
-source="greybird-$pkgver.tar.gz::https://github.com/shimmerproject/Greybird/archive/v$pkgver.tar.gz"
+source="greybird-$pkgver.tar.gz::https://github.com/shimmerproject/Greybird/archive/v$pkgver.tar.gz
+ gtk-3.14-fix.patch
+ "
_builddir="$srcdir"/Greybird-$pkgver
prepare() {
@@ -68,6 +70,9 @@ metacity() { _mv "Greybird Metacity themes" metacity metacity-1; }
xfwm4() { _mv "Greybird Xfce4 themes" xfwm4 xfwm4 xfwm4_compact; }
_notify() { _mv "Greybird Xfce4-notifyd themes" xfce4-notifyd xfce-notify-4.0; }
-md5sums="da5345a9b253fd9bf5ea101a3ecc2fb5 greybird-1.4.tar.gz"
-sha256sums="e4d42de800d32ce4c7670afd546aa3ff37716e05fdff821a3d803b8d0603c571 greybird-1.4.tar.gz"
-sha512sums="8b414373f01655673e29c7454f88ffffade10b8a0883e777b1b5f41706042253d04ff5f886bb70a0e01a869f4ee5cb2dbe50dde4b48df5e4956d6446aaf16621 greybird-1.4.tar.gz"
+md5sums="da5345a9b253fd9bf5ea101a3ecc2fb5 greybird-1.4.tar.gz
+ef3882cc1ea6c00fb1c372c911b563fe gtk-3.14-fix.patch"
+sha256sums="e4d42de800d32ce4c7670afd546aa3ff37716e05fdff821a3d803b8d0603c571 greybird-1.4.tar.gz
+00d0c58a96c5c1090adcf8ec479d5d608e68d1141e79cebb1112f3430ae7a482 gtk-3.14-fix.patch"
+sha512sums="8b414373f01655673e29c7454f88ffffade10b8a0883e777b1b5f41706042253d04ff5f886bb70a0e01a869f4ee5cb2dbe50dde4b48df5e4956d6446aaf16621 greybird-1.4.tar.gz
+6cb7912dda0b82065e58a51533ce0b7d6341af5e7e996dd2f2870c8e2db6c439e7c47f12e7bccb24c74021de6516ebbc9a0ac32c5323b048002b7abf87365722 gtk-3.14-fix.patch"
diff --git a/testing/greybird-themes/gtk-3.14-fix.patch b/testing/greybird-themes/gtk-3.14-fix.patch
new file mode 100644
index 000000000..61f23c5c6
--- /dev/null
+++ b/testing/greybird-themes/gtk-3.14-fix.patch
@@ -0,0 +1,17 @@
+diff --git a/gtk-3.0/gtk-widgets.css b/gtk-3.0/gtk-widgets.css
+index 3428f75..619f566 100644
+--- a/gtk-3.0/gtk-widgets.css
++++ b/gtk-3.0/gtk-widgets.css
+@@ -4153,3 +4153,11 @@ GtkBubbleWindow .toolbar {
+ box-shadow: 0 3px 5px alpha(black, 0.5),
+ 0 0 0 1px alpha(black, 0.2);
+ }
++
++.toolbar .button , .toolbar .button:insensitive {
++ border: 1px solid transparent;
++ background: none;
++ border-color: none;
++ box-shadow: inset 0 0 ,
++ inset 0 0 ;
++}
+