summaryrefslogtreecommitdiffstats
path: root/testing/libx86/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-26 08:57:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-26 08:57:34 +0000
commit0c5ec46423f591c5d03125ec2e7f51442823a85a (patch)
treed0b68a202892cf6852eb1703a9d10f2106865c1e /testing/libx86/APKBUILD
parentb5574acc6732b7d7eb5f78d0246e6ae15b0e282a (diff)
downloadaports-0c5ec46423f591c5d03125ec2e7f51442823a85a.tar.bz2
aports-0c5ec46423f591c5d03125ec2e7f51442823a85a.tar.xz
testing/libx86: new aport
Library for making real-mode x86 calls http://www.codon.org.uk/~mjg59/libx86 ref #960
Diffstat (limited to 'testing/libx86/APKBUILD')
-rw-r--r--testing/libx86/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/libx86/APKBUILD b/testing/libx86/APKBUILD
new file mode 100644
index 000000000..cfd63e3f7
--- /dev/null
+++ b/testing/libx86/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libx86
+pkgver=1.1
+pkgrel=0
+pkgdesc="Library for making real-mode x86 calls"
+url="http://www.codon.org.uk/~mjg59/libx86"
+arch="x86 x86_64"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://www.codon.org.uk/~mjg59/libx86/downloads/libx86-$pkgver.tar.gz
+ libx86-add-pkgconfig.patch
+ libx86-mmap-offset.patch
+ "
+
+_builddir="$srcdir"/libx86-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make BACKEND=x86emu || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="41bee1f8e22b82d82b5f7d7ba51abc2a libx86-1.1.tar.gz
+7958f84486ebe60cebd85ae3807c5e58 libx86-add-pkgconfig.patch
+cfa7e8b178d2d14431dc0c3e9d5f842d libx86-mmap-offset.patch"