summaryrefslogtreecommitdiffstats
path: root/testing/lua-telescope
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2012-05-17 07:48:02 +0000
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2012-05-17 07:50:06 +0000
commit27acccfbf15d236d3c87500909d786ee12e87e01 (patch)
tree9d3dc5e10d635948a204cd97c2eb081c47cd9dab /testing/lua-telescope
parent4bcd5a5957944a393e078261d9bbae8595d00ea3 (diff)
downloadaports-27acccfbf15d236d3c87500909d786ee12e87e01.tar.bz2
aports-27acccfbf15d236d3c87500909d786ee12e87e01.tar.xz
testing/lua-telescope: package added
Diffstat (limited to 'testing/lua-telescope')
-rw-r--r--testing/lua-telescope/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/lua-telescope/APKBUILD b/testing/lua-telescope/APKBUILD
new file mode 100644
index 000000000..4ffe28045
--- /dev/null
+++ b/testing/lua-telescope/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer:
+pkgname=lua-telescope
+pkgver=0.4.1
+pkgrel=0
+pkgdesc="Test library for Lua"
+url=https://github.com/norman/telescope
+arch=noarch
+license=MIT
+depends=lua
+source=https://github.com/downloads/norman/telescope/telescope-$pkgver.tar.gz
+
+_builddir=$srcdir/telescope-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ :
+}
+
+package() {
+ cd "$_builddir"
+ local dir=$pkgdir/usr/share/lua/5.1
+ install -d "$dir"
+ install -m 644 telescope.lua "$dir"
+}
+
+md5sums="e240350716994873fe1ad7f67918c3b2 telescope-0.4.1.tar.gz"