summaryrefslogtreecommitdiffstats
path: root/testing/openjade
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2015-02-26 09:13:40 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2015-02-26 09:13:40 +0000
commit7a11e9d1cea3dd140effa30651ee9cd288fca710 (patch)
tree8c4822b3c618ab71a87a84ddbf7a35ea6213affc /testing/openjade
parent6b0d2ba29616074b9743a6e7e0f667112ae89944 (diff)
downloadaports-7a11e9d1cea3dd140effa30651ee9cd288fca710.tar.bz2
aports-7a11e9d1cea3dd140effa30651ee9cd288fca710.tar.xz
testing/openjade: new aport
An implementation of DSSSL, a style language to format SGML or XML documents.
Diffstat (limited to 'testing/openjade')
-rw-r--r--testing/openjade/APKBUILD70
-rw-r--r--testing/openjade/openjade-1.3.2-deplibs.patch40
-rw-r--r--testing/openjade/openjade-1.3.2-gcc46.patch74
-rw-r--r--testing/openjade/openjade-1.3.2-ldflags.patch13
-rw-r--r--testing/openjade/openjade-1.3.2-libosp-la.patch38
-rw-r--r--testing/openjade/openjade-1.3.2-msggen.pl.patch32
-rw-r--r--testing/openjade/openjade-1.3.2-respect-ldflags.patch12
7 files changed, 279 insertions, 0 deletions
diff --git a/testing/openjade/APKBUILD b/testing/openjade/APKBUILD
new file mode 100644
index 000000000..9331daf50
--- /dev/null
+++ b/testing/openjade/APKBUILD
@@ -0,0 +1,70 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=openjade
+pkgver=1.3.2
+pkgrel=0
+pkgdesc="Implementation of the DSSSL style language"
+url="http://openjade.sourceforge.net"
+arch="all"
+license="Custom"
+depends=
+depends_dev=
+makedepends="$depends_dev opensp-dev"
+install=
+subpackages="$pkgname-dev"
+source="http://prdownloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ openjade-1.3.2-msggen.pl.patch
+ openjade-1.3.2-ldflags.patch
+ openjade-1.3.2-deplibs.patch
+ openjade-1.3.2-libosp-la.patch
+ openjade-1.3.2-gcc46.patch
+ openjade-1.3.2-respect-ldflags.patch
+ "
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/lib/*.la || return 0
+}
+
+md5sums="7df692e3186109cc00db6825b777201e openjade-1.3.2.tar.gz
+a175eea2fec14f533ec90d515a598606 openjade-1.3.2-msggen.pl.patch
+56077cda2d805784bc6b0564c4649c3a openjade-1.3.2-ldflags.patch
+f9d0ce619e55260c7500b1845aebbb2b openjade-1.3.2-deplibs.patch
+dcbde56f8755c9c777c1adae43853712 openjade-1.3.2-libosp-la.patch
+3f77731285d65aa2373f57f679d5ba28 openjade-1.3.2-gcc46.patch
+223fa1d9f89bbd7f31d60910752e6f10 openjade-1.3.2-respect-ldflags.patch"
+sha256sums="1d2d7996cc94f9b87d0c51cf0e028070ac177c4123ecbfd7ac1cb8d0b7d322d1 openjade-1.3.2.tar.gz
+7213377d218e8808617883df6bfe4a21696a1af50c64d0e491b9f85534e06ffc openjade-1.3.2-msggen.pl.patch
+7fd651fb682d70a3f5062a65d0da60bebdc5b958cc936d7980339f49b360c3a0 openjade-1.3.2-ldflags.patch
+93905d0b4878f580fece323c1ebb4b5d5db05f1e6f06dde39cfd9b2dd0a95433 openjade-1.3.2-deplibs.patch
+c0922350016fbd2784f9080a67b0f8d6171884d506216d7983dfdf95ef15ab11 openjade-1.3.2-libosp-la.patch
+fb873273dc31becdab60ff669c683bbb363ad3abb08949ad0ac54cfc28cf2214 openjade-1.3.2-gcc46.patch
+498b8c9eb8eb4adea6bbe63c3e85f7a1aa619734caecd7ed4c0d70487850778b openjade-1.3.2-respect-ldflags.patch"
+sha512sums="c39f70ec8020bd7a2b3e125cbd146b49ddb57910a042bd212da02722617ed5681f32dab60acc26ab89ac658997c6f604911d7be3be391d6278267481f3bcf2f1 openjade-1.3.2.tar.gz
+8afe0dd887a2e997922ca4d13f70a11205d224537c920a806b310bdc719005124f3cd6fa075225b83b86a9f0e04496011460962e82aa896b9a16632fbb2da40f openjade-1.3.2-msggen.pl.patch
+6112fbc474f0f2c3c024040b42b13290ba2763381b7f99071d7d9d4f8d11bf1087a2c319eba9f0006e2cc067a14a52cedde98444338b180f9566172b52c044ec openjade-1.3.2-ldflags.patch
+4a7df423c8b8ad15a1a39900c1bb6882157534c981a9c0679b2c6d71a435b6bf3adf27052799a9eb1dd4f6ecd7e19be72889d9a55c7511ffde9dd11f4c558d9e openjade-1.3.2-deplibs.patch
+9b73b95ce3ac1d0042641eb0ddbb5ce753d2fd639dab026b9eab0f45bb3231515c69670f02c2a0793d950b6a6276f94e838d273f01e43694e97525af65903a0e openjade-1.3.2-libosp-la.patch
+df222938e4a04d27618540592e61b8d71fe42caaa4d8aeb90bfcd338efb1ff7903ea860dc460b65a69adf1ccf300a7d67459ff4950a35d9a35569fb8b3ed1438 openjade-1.3.2-gcc46.patch
+bca7e9550329bc033a1df4ca78bc1ae75b12f27fdecc6aafff136fd81c93f88045ca675dd03e711b4d428a3de832f3bfa703d639319a2b348a2f8268091658d8 openjade-1.3.2-respect-ldflags.patch"
diff --git a/testing/openjade/openjade-1.3.2-deplibs.patch b/testing/openjade/openjade-1.3.2-deplibs.patch
new file mode 100644
index 000000000..3466ad7d8
--- /dev/null
+++ b/testing/openjade/openjade-1.3.2-deplibs.patch
@@ -0,0 +1,40 @@
+diff -urNp openjade-1.3.2/grove/Makefile.sub devel/grove/Makefile.sub
+--- openjade-1.3.2/grove/Makefile.sub 2002-10-20 23:47:24.000000000 +0200
++++ devel/grove/Makefile.sub 2007-07-23 15:39:23.000000000 +0200
+@@ -1,4 +1,4 @@
+ LTVERSION=0:1:0
+ LIB=ogrove
+-DEPLIBS=-lm
++DEPLIBS=-lm -lstdc++
+ OBJS=Node.o LocNode.o
+diff -urNp openjade-1.3.2/spgrove/Makefile.sub devel/spgrove/Makefile.sub
+--- openjade-1.3.2/spgrove/Makefile.sub 2002-11-15 23:46:50.000000000 +0100
++++ devel/spgrove/Makefile.sub 2007-07-23 16:06:13.000000000 +0200
+@@ -1,9 +1,10 @@
+ LTVERSION=0:1:0
+ LIB=ospgrove
+ INCLUDE=-I$(srcdir)/../grove
+-DEPLIBS=-lm -L$(TOP)/grove -L$(TOP)/grove/.libs \
++DEPLIBS=$(TOP)/grove/libogrove.la \
++ -lm -losp -L$(TOP)/grove/.libs \
+ -L$(TOP)/lib -L$(TOP)/lib/.libs \
+- $(LIB_THREADS)
++ $(LIB_THREADS) -lstdc++
+ OBJS=GroveApp.o GroveBuilder.o SdNode.o
+ GENSRCS=grove_inst.cxx
+
+diff -urNp openjade-1.3.2/style/Makefile.sub devel/style/Makefile.sub
+--- openjade-1.3.2/style/Makefile.sub 2003-04-18 19:18:10.000000000 +0200
++++ devel/style/Makefile.sub 2007-07-23 16:08:26.000000000 +0200
+@@ -1,8 +1,8 @@
+ LTVERSION=0:1:0
+ LIB=ostyle
+-DEPLIBS=-lm -L$(TOP)/grove -L$(TOP)/grove/.libs \
+- -L$(TOP)/lib -L$(TOP)/lib/.libs \
+- -L$(TOP)/spgrove -L$(TOP)/spgrove/.libs
++DEPLIBS=$(TOP)/grove/libogrove.la $(TOP)/spgrove/libospgrove.la \
++ -lm -losp -L$(TOP)/lib -L$(TOP)/lib/.libs -L$(TOP)/grove/.libs \
++ -L$(TOP)/spgrove -L$(TOP)/spgrove/.libs -lstdc++
+ OBJS=LangObj.o \
+ Collector.o \
+ DssslApp.o \
diff --git a/testing/openjade/openjade-1.3.2-gcc46.patch b/testing/openjade/openjade-1.3.2-gcc46.patch
new file mode 100644
index 000000000..e947ffe12
--- /dev/null
+++ b/testing/openjade/openjade-1.3.2-gcc46.patch
@@ -0,0 +1,74 @@
+--- openjade-1.3.2-orig//jade/TeXFOTBuilder.cxx 2011-05-02 22:08:49.274006803 +0000
++++ openjade-1.3.2-orig//jade/TeXFOTBuilder.cxx 2011-05-02 22:14:09.849006939 +0000
+@@ -88,6 +88,8 @@
+ value.convertString(nic_.placement);
+ }
+ ExtensionFlowObj *copy() const { return new PageFloatFlowObj(*this); }
++ public:
++ PageFloatFlowObj() {}
+ private:
+ PageFloatNIC nic_;
+ StringC name_;
+@@ -101,6 +103,8 @@
+ fotb.endPageFootnote();
+ }
+ ExtensionFlowObj *copy() const { return new PageFootnoteFlowObj(*this); }
++ public:
++ PageFootnoteFlowObj() {}
+ private:
+ };
+ //////////////////////////////////////////////////////////////////////
+--- openjade-1.3.2-orig//jade/TransformFOTBuilder.cxx 2011-05-02 22:08:49.275006803 +0000
++++ openjade-1.3.2-orig//jade/TransformFOTBuilder.cxx 2011-05-02 22:18:31.614007052 +0000
+@@ -41,6 +41,7 @@
+ };
+ class EntityRefFlowObj : public TransformExtensionFlowObj {
+ public:
++ EntityRefFlowObj() {}
+ void atomic(TransformFOTBuilder &fotb, const NodePtr &) const {
+ fotb.entityRef(name_);
+ }
+@@ -56,6 +57,7 @@
+ };
+ class ProcessingInstructionFlowObj : public TransformExtensionFlowObj {
+ public:
++ ProcessingInstructionFlowObj() {}
+ void atomic(TransformFOTBuilder &fotb, const NodePtr &) const {
+ fotb.processingInstruction(data_);
+ }
+@@ -98,6 +100,8 @@
+ }
+ }
+ ExtensionFlowObj *copy() const { return new EmptyElementFlowObj(*this); }
++ public:
++ EmptyElementFlowObj() {}
+ private:
+ ElementNIC nic_;
+ };
+@@ -133,6 +137,8 @@
+ }
+ }
+ ExtensionFlowObj *copy() const { return new ElementFlowObj(*this); }
++ public:
++ ElementFlowObj() {}
+ private:
+ ElementNIC nic_;
+ };
+@@ -150,6 +156,8 @@
+ value.convertString(systemId_);
+ }
+ ExtensionFlowObj *copy() const { return new EntityFlowObj(*this); }
++ public:
++ EntityFlowObj() {};
+ private:
+ StringC systemId_;
+ };
+@@ -174,6 +182,8 @@
+ }
+ }
+ ExtensionFlowObj *copy() const { return new DocumentTypeFlowObj(*this); }
++ public:
++ DocumentTypeFlowObj() {}
+ private:
+ DocumentTypeNIC nic_;
+ };
diff --git a/testing/openjade/openjade-1.3.2-ldflags.patch b/testing/openjade/openjade-1.3.2-ldflags.patch
new file mode 100644
index 000000000..4ddd4d414
--- /dev/null
+++ b/testing/openjade/openjade-1.3.2-ldflags.patch
@@ -0,0 +1,13 @@
+Index: openjade-1.3.2/jade/Makefile.sub
+===================================================================
+--- openjade-1.3.2.orig/jade/Makefile.sub
++++ openjade-1.3.2/jade/Makefile.sub
+@@ -4,7 +4,7 @@ OBJS=jade.o SgmlFOTBuilder.o RtfFOTBuild
+ INCLUDE=-I$(srcdir)/../grove -I$(srcdir)/../spgrove -I$(srcdir)/../style
+ # XLIBS=../style/libostyle.a ../spgrove/libospgrove.a ../grove/libogrove.a \
+ # ../lib/libosp.a
+-XLIBS=../style/libostyle.a ../spgrove/libospgrove.a ../grove/libogrove.a $(splibdir)/libosp.a
++XLIBS=../style/libostyle.a ../grove/libogrove.a ../spgrove/libospgrove.a $(splibdir)/libosp.a
+ GENSRCS=JadeMessages.h HtmlMessages.h RtfMessages.h TeXMessages.h \
+ HtmlFOTBuilder_inst.cxx RtfFOTBuilder_inst.cxx TeXFOTBuilder_inst.cxx \
+ TransformFOTBuilder_inst.cxx MifMessages.h MifFOTBuilder_inst.cxx
diff --git a/testing/openjade/openjade-1.3.2-libosp-la.patch b/testing/openjade/openjade-1.3.2-libosp-la.patch
new file mode 100644
index 000000000..d106771b5
--- /dev/null
+++ b/testing/openjade/openjade-1.3.2-libosp-la.patch
@@ -0,0 +1,38 @@
+diff -u /var/tmp/portage/app-text/openjade-1.3.2-r1/work/openjade-1.3.2/jade/Makefile.sub /tmp/buffer-content-5978gFR
+--- a/jade/Makefile.sub 2009-11-19 17:21:46.000000000 -0500
++++ b/jade/Makefile.sub 2009-11-19 17:23:24.000000000 -0500
+@@ -4,7 +4,8 @@
+ INCLUDE=-I$(srcdir)/../grove -I$(srcdir)/../spgrove -I$(srcdir)/../style
+ # XLIBS=../style/libostyle.a ../spgrove/libospgrove.a ../grove/libogrove.a \
+ # ../lib/libosp.a
+-XLIBS=../style/libostyle.a ../grove/libogrove.a ../spgrove/libospgrove.a $(splibdir)/libosp.a
++XLIBS=../style/libostyle.a ../grove/libogrove.a ../spgrove/libospgrove.a -losp
++EXT_LIBS=-L$(splibdir) -losp $(LIBS)
+ GENSRCS=JadeMessages.h HtmlMessages.h RtfMessages.h TeXMessages.h \
+ HtmlFOTBuilder_inst.cxx RtfFOTBuilder_inst.cxx TeXFOTBuilder_inst.cxx \
+ TransformFOTBuilder_inst.cxx MifMessages.h MifFOTBuilder_inst.cxx
+
+
+diff -u /var/tmp/portage/app-text/openjade-1.3.2-r1/work/openjade-1.3.2/Makefile.prog.in /tmp/buffer-content-5978T7K
+--- a/Makefile.prog.in 2002-01-22 06:57:53.000000000 -0500
++++ b/Makefile.prog.in 2009-11-19 17:23:05.000000000 -0500
+@@ -10,16 +10,15 @@
+ top_builddir=@TOP@
+ LINKFLAGS = @LINKFLAGS@
+
+-ALL_LIBS = $(XLIBS) $(LIBS)
+ Makefile.lt:
+- echo 'LT_LIBS='`echo $(ALL_LIBS)|sed 's/\.a/.la/g'` >Makefile.lt
++ echo 'LT_LIBS='`echo $(XLIBS)|sed 's/\.a/.la/g'` >Makefile.lt
+
+ PROG:=$(shell echo "$(PROG)" | sed '@program_transform_name@')
+
+ all: $(PROG)
+
+ $(PROG): $(OBJS) $(COBJS) $(LT_LIBS)
+- $(LIBTOOL) --mode=link $(CXX) $(LINKFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(COBJS) $(LT_LIBS)
++ $(LIBTOOL) --mode=link $(CXX) $(LINKFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(COBJS) $(LT_LIBS) $(EXT_LIBS)
+
+ install: $(PROG)
+ -test -d $(DESTDIR)$(bindir) || \
+
diff --git a/testing/openjade/openjade-1.3.2-msggen.pl.patch b/testing/openjade/openjade-1.3.2-msggen.pl.patch
new file mode 100644
index 000000000..2f8745642
--- /dev/null
+++ b/testing/openjade/openjade-1.3.2-msggen.pl.patch
@@ -0,0 +1,32 @@
+Use Getopt::Std in place of getopts.pl.
+https://bugs.gentoo.org/show_bug.cgi?id=420083
+
+--- a/msggen.pl
++++ b/msggen.pl
+@@ -4,6 +4,7 @@
+ # See the file COPYING for copying permission.
+
+ use POSIX;
++use Getopt::Std;
+
+ # Package and version.
+ $package = 'openjade';
+@@ -18,8 +19,7 @@
+ undef $opt_l;
+ undef $opt_p;
+ undef $opt_t;
+-do 'getopts.pl';
+-&Getopts('l:p:t:');
++getopts('l:p:t:');
+ $module = $opt_l;
+ $pot_file = $opt_p;
+
+@@ -72,7 +72,7 @@
+ else {
+ $field[0] =~ /^[IWQXE][0-9]$/ || &error("invalid first field");;
+ $type[$num] = substr($field[0], 0, 1);
+- $argc = int(substr($field[0], 1, 1));
++ $argc = substr($field[0], 1, 1);
+ }
+ $nargs[$num] = $argc;
+ $field[1] =~ /^[a-zA-Z_][a-zA-Z0-9_]+$/ || &error("invalid tag"); \ No newline at end of file
diff --git a/testing/openjade/openjade-1.3.2-respect-ldflags.patch b/testing/openjade/openjade-1.3.2-respect-ldflags.patch
new file mode 100644
index 000000000..51bd0b27d
--- /dev/null
+++ b/testing/openjade/openjade-1.3.2-respect-ldflags.patch
@@ -0,0 +1,12 @@
+diff -ru a/Makefile.lib.in b/Makefile.lib.in
+--- a/Makefile.lib.in 2002-01-22 05:57:53.000000000 -0600
++++ b/Makefile.lib.in 2009-01-04 16:15:41.000000000 -0600
+@@ -23,7 +23,7 @@
+ echo 'LT_OBJS='`echo $(OBJS)|sed 's/\.o/.lo/g'` >Makefile.lt
+
+ lib$(LIB).la: $(LT_OBJS)
+- $(LIBTOOL) --mode=link $(CC) $(LINKFLAGS) -o lib$(LIB).la $(LT_OBJS) \
++ $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) $(LINKFLAGS) -o lib$(LIB).la $(LT_OBJS) \
+ -rpath $(libdir) -version-info $(LTVERSION) $(DEPLIBS)
+
+ install: