summaryrefslogtreecommitdiffstats
path: root/testing/pep8
diff options
context:
space:
mode:
authorsystmkor <systmkor@gmail.com>2015-01-21 15:06:55 -0800
committerNatanael Copa <ncopa@alpinelinux.org>2015-01-25 11:15:57 +0000
commit3372e66a475ccf2a7f2750c62c6cd4c6545bf625 (patch)
treebf7ecb5080c3a6b010cfe41c86d26b5a29cab189 /testing/pep8
parentba86e3f8b7cb1bebf510e912d99c5cfed3c77a45 (diff)
downloadaports-3372e66a475ccf2a7f2750c62c6cd4c6545bf625.tar.bz2
aports-3372e66a475ccf2a7f2750c62c6cd4c6545bf625.tar.xz
testing/pep8: new aport
pep8 is a tool to check your Python code against some of the style conventions in PEP 8. http://github.com/jcrocholl/pep8/
Diffstat (limited to 'testing/pep8')
-rw-r--r--testing/pep8/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/pep8/APKBUILD b/testing/pep8/APKBUILD
new file mode 100644
index 000000000..37c46bef8
--- /dev/null
+++ b/testing/pep8/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Orion <systmkor@gmail.com>
+# Maintainer: Orion <systmkor@gmail.com>
+# Reference
+# https://www.archlinux.org/packages/community/any/pep8/
+# https://pypi.python.org/pypi/pep8
+pkgname=pep8
+pkgver=1.5.7
+pkgrel=0
+pkgdesc="pep8 is a tool to check your Python code against some of the style conventions in PEP 8."
+url="http://github.com/jcrocholl/pep8/"
+arch="noarch"
+license="custom:Expat"
+depends="python py-setuptools"
+depends_dev=""
+makedepends=""
+install=""
+subpackages=""
+source="https://pypi.python.org/packages/source/p/pep8/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="f6adbdd69365ecca20513c709f9b7c93 pep8-1.5.7.tar.gz"
+sha256sums="15b42131b25f376165d195fe4e17b0a28311182aaf9330d5eb575bbeda5a6989 pep8-1.5.7.tar.gz"
+sha512sums="ae5cc6cc47d71e90059fec0c89f5e8e7b71b08d185c95b0c8cf0aa9acaee4841d0cfc617fb1ca6d7af7f4721480a1992b6178dc845d80dfe87fe3792d515a3eb pep8-1.5.7.tar.gz"