summaryrefslogtreecommitdiffstats
path: root/testing/perl-libapreq2/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2013-09-01 14:53:11 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2013-09-01 14:53:11 +0000
commitee526693d375a4cd6d2a7b80117ae162c7f11695 (patch)
tree5c743583e36d06cf35e11d544d18057f5cd4262d /testing/perl-libapreq2/APKBUILD
parent2ea6a936fd59d316b21bf9899004fec28b05c4a0 (diff)
downloadaports-ee526693d375a4cd6d2a7b80117ae162c7f11695.tar.bz2
aports-ee526693d375a4cd6d2a7b80117ae162c7f11695.tar.xz
testing/perl-libapreq2: disable compile until apache2 error is fixed
Diffstat (limited to 'testing/perl-libapreq2/APKBUILD')
-rw-r--r--testing/perl-libapreq2/APKBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/testing/perl-libapreq2/APKBUILD b/testing/perl-libapreq2/APKBUILD
index 9a0003dc2..bd2e723de 100644
--- a/testing/perl-libapreq2/APKBUILD
+++ b/testing/perl-libapreq2/APKBUILD
@@ -6,13 +6,13 @@ pkgver=2.13
pkgrel=0
pkgdesc="Perl module for libapreq2"
url="http://search.cpan.org/dist/libapreq2/"
-arch="all"
+#arch="all"
license="GPL PerlArtistic"
cpandepends=""
cpanmakedepends=""
depends="$cpandepends"
subpackages="$pkgname-doc $pkgname-dev"
-makedepends="perl-extutils-xsbuilder libtool"
+makedepends="perl-extutils-xsbuilder libtool apache2-dev"
source="http://search.cpan.org/CPAN/authors/id/I/IS/ISAAC/$_pkgreal-$pkgver.tar.gz
libapreq2-2.08-doc.patch"
_builddir="$srcdir/$_pkgreal-$pkgver"
@@ -29,8 +29,12 @@ prepare() {
build() {
cd $_builddir
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL --with-apache2-apxs=/usr/bin/apxs \
- --enable-perl-glue
+# PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor \
+ ./configure --with-perl-opts="INSTALLDIRS=vendor" \
+ --with-apache2-apxs=/usr/bin/apxs \
+ --with-apache2-httpd=/usr/sbin/httpd \
+ --enable-perl-glue
+
make || return 1
}