summaryrefslogtreecommitdiffstats
path: root/testing/py-ask
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-15 18:30:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:33 +0000
commit1796e763314a5fe4b44b7889212eabe9ff05cc22 (patch)
treee75db7fbca074ca9b4349dad3411fc4d38ee2d01 /testing/py-ask
parente256d766ce52d1e46dfec3678748255e0308c3cc (diff)
downloadaports-1796e763314a5fe4b44b7889212eabe9ff05cc22.tar.bz2
aports-1796e763314a5fe4b44b7889212eabe9ff05cc22.tar.xz
testing/py-ask: new aport
An easy input validation for Python https://github.com/chive/ask
Diffstat (limited to 'testing/py-ask')
-rw-r--r--testing/py-ask/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-ask/APKBUILD b/testing/py-ask/APKBUILD
new file mode 100644
index 000000000..111d68947
--- /dev/null
+++ b/testing/py-ask/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-ask
+_pkgname=ask
+pkgver=0.0.6
+pkgrel=0
+pkgdesc="An easy input validation for Python"
+url="https://github.com/chive/ask"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="37a64aec8fa58e868c00873e27ff5c14 ask-0.0.6.tar.gz"
+sha256sums="660b5b59379a4a08018cb5d3688b9e5261a4be55229ae97561b6f29951ac2188 ask-0.0.6.tar.gz"
+sha512sums="a43a3b2157b91bd48c68bedf01306f25645926fa0f59494de2c5b6869384e2f53d34392514dc37bb05d4dc98fd4529d9dde170496cb150282cbc39e8d8cb48f3 ask-0.0.6.tar.gz"