summaryrefslogtreecommitdiffstats
path: root/testing/py-awake
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-03-01 17:20:24 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-03-04 09:50:14 +0000
commit721b7075ce03556841a35a6dec68092d625d1cb0 (patch)
treeb8672628d8c0ddf78851afe38cdd5066119aac02 /testing/py-awake
parent100a5daedf365f523939bb4c4830f9f03f24f195 (diff)
downloadaports-721b7075ce03556841a35a6dec68092d625d1cb0.tar.bz2
aports-721b7075ce03556841a35a6dec68092d625d1cb0.tar.xz
testing/py-awake: new aport
A command and library to "wake on lan" a remote host. Website: https://github.com/cyraxjoe/awake
Diffstat (limited to 'testing/py-awake')
-rw-r--r--testing/py-awake/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/testing/py-awake/APKBUILD b/testing/py-awake/APKBUILD
new file mode 100644
index 000000000..19271d382
--- /dev/null
+++ b/testing/py-awake/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-awake
+_pkgname=awake
+pkgver=1.0
+pkgrel=0
+pkgdesc="A command and library to 'wake on lan' a remote host"
+url="https://github.com/cyraxjoe/awake"
+arch="noarch"
+license="GPL3"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://github.com/cyraxjoe/awake/archive/v$pkgver.zip"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+ cd test
+ python -m unittest discover || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+doc() {
+ # Doc files
+ _docs="CHANGES LICENSE README"
+ for _doc in $_docs; do
+ install -Dm644 "$srcdir"/$_pkgname-$pkgver/$_doc \
+ "$subpkgdir"/usr/share/doc/$pkgname/$_doc || return 1
+ done
+}
+
+md5sums="dda00f336d795c410239b48e7e3eb3e7 v1.0.zip"
+sha256sums="f45d0062198d8bb2022817b12a19aaa51c6be78f37f95df8a486ddec9b07caed v1.0.zip"
+sha512sums="6b7ec80ebe5eab5ebbb569aa9569257fa10e9584725bb1171f3b3aac7f6bede4652f5e144921ed5d39631b90dcdceff2c6bbc594b4537e46c9347c9f54ba99e8 v1.0.zip"