summaryrefslogtreecommitdiffstats
path: root/testing/py-flake8
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-05 20:45:37 +0000
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-09-08 14:35:47 +0200
commitaef2e521570ddc446241d42f453683dee7310339 (patch)
tree6fadffab5c71ca7260c676fff539661227a00157 /testing/py-flake8
parentb287f18488a2554062b7ecd187218f5cee5e44b6 (diff)
downloadaports-aef2e521570ddc446241d42f453683dee7310339.tar.bz2
aports-aef2e521570ddc446241d42f453683dee7310339.tar.xz
testing/py-flake8: new aport
A modular source code checker https://bitbucket.org/tarek/flake8/wiki/Home
Diffstat (limited to 'testing/py-flake8')
-rw-r--r--testing/py-flake8/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flake8/APKBUILD b/testing/py-flake8/APKBUILD
new file mode 100644
index 000000000..6da9a0c8c
--- /dev/null
+++ b/testing/py-flake8/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flake8
+_pkgname=flake8
+pkgver=2.0
+pkgrel=0
+pkgdesc="A modular source code checker"
+url="https://bitbucket.org/tarek/flake8/wiki/Home"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools py-mccabe py-pep8 pyflakes"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="176c6b3613777122721db181560aa1e3 flake8-2.0.tar.gz"
+sha256sums="8dce4f7e64cc202cc6da93eab84b2ce660110ff684b6738bba64a0a431b3bc69 flake8-2.0.tar.gz"
+sha512sums="6e3d8030562c4489dce8d4b17464ea8c0239b7c28fcefb7c67bff645e18628bc3074ff0ff197ab54228544d0ff85c2ff9509502c8f98371d8dc5df6f1e3ec047 flake8-2.0.tar.gz"