summaryrefslogtreecommitdiffstats
path: root/testing/py-flask-autoindex
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-14 12:53:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:31 +0000
commitb6dcd1b0cb9f8647a337ce48b47adfc35974604f (patch)
tree118bdc5d2ae13cf96bd2a1b2da2f45ed2473803c /testing/py-flask-autoindex
parenta23c64728fe12e902fa9216daee627b209e82286 (diff)
downloadaports-b6dcd1b0cb9f8647a337ce48b47adfc35974604f.tar.bz2
aports-b6dcd1b0cb9f8647a337ce48b47adfc35974604f.tar.xz
testing/py-flask-autoindex: new aport
Flask autoindex https://pypi.python.org/pypi/Flask-AutoIndex
Diffstat (limited to 'testing/py-flask-autoindex')
-rw-r--r--testing/py-flask-autoindex/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flask-autoindex/APKBUILD b/testing/py-flask-autoindex/APKBUILD
new file mode 100644
index 000000000..2bfdad1de
--- /dev/null
+++ b/testing/py-flask-autoindex/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-autoindex
+_pkgname=Flask-AutoIndex
+pkgver=0.5
+pkgrel=0
+pkgdesc="Flask autoindex"
+url="https://pypi.python.org/pypi/Flask-AutoIndex"
+arch="noarch"
+license="BSD"
+depends="python py-flask"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="24984602365704737468bb4d2586a739 Flask-AutoIndex-0.5.tar.gz"
+sha256sums="12904135a3092dfdbfc3eec0f573ec0cf483e46252e7e12fedff89407a9f2c75 Flask-AutoIndex-0.5.tar.gz"
+sha512sums="715c27976f065aeee995adcbc6405a7eab2f197c69712181774e7474f04c3419358beb90663f7ec043cf3862d23daca7aa2add29f1708b26b21118444fe3caeb Flask-AutoIndex-0.5.tar.gz"