summaryrefslogtreecommitdiffstats
path: root/testing/py-flask-qrcode
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-08-18 19:06:58 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2014-08-21 07:53:24 +0000
commit1de6c2e9439443fa823810c93b8dab1e8bb7f010 (patch)
tree71fac778bb33b0af90a949236e29948486c4d007 /testing/py-flask-qrcode
parentcfd6e6e20e4ec5ef33310d7698bd9bce7f440f4b (diff)
downloadaports-1de6c2e9439443fa823810c93b8dab1e8bb7f010.tar.bz2
aports-1de6c2e9439443fa823810c93b8dab1e8bb7f010.tar.xz
testing/py-flask-qrcode: new aport
A simple flask extension to render QR codes on template. https://github.com/marcoagner/Flask-QRcode
Diffstat (limited to 'testing/py-flask-qrcode')
-rw-r--r--testing/py-flask-qrcode/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flask-qrcode/APKBUILD b/testing/py-flask-qrcode/APKBUILD
new file mode 100644
index 000000000..99893025a
--- /dev/null
+++ b/testing/py-flask-qrcode/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-qrcode
+_pkgname=Flask-QRcode
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="A simple flask extension to render QR codes on template"
+url="https://github.com/marcoagner/Flask-QRcode"
+arch="noarch"
+license="BSD"
+depends="python py-flask py-qrcode"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="e03644e1e90737d84e3c4efd3b211d95 Flask-QRcode-0.5.0.tar.gz"
+sha256sums="dcd2ae55ec9f57ef9f625bc8b86ee939b00fb76cffc24ac449746ea8355e3147 Flask-QRcode-0.5.0.tar.gz"
+sha512sums="c79b5f4cc3118d1e346404dcc973f6d20aef0d8333d4a3ecc66f7fc5f7093072e45cc5b2b69bc162e849a5aa6ce3581061ff10c6f4a7021d30dcc2afa73203ce Flask-QRcode-0.5.0.tar.gz"