summaryrefslogtreecommitdiffstats
path: root/testing/py-linkedin
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-06 21:12:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:15 +0000
commit0702a49d78b56a1be18cb6266753030104b9ba44 (patch)
tree3353d21d099125f555a04145659ae52538fa243a /testing/py-linkedin
parentf825fe5642d8083bf10278de2bbd2cb432515045 (diff)
downloadaports-0702a49d78b56a1be18cb6266753030104b9ba44.tar.bz2
aports-0702a49d78b56a1be18cb6266753030104b9ba44.tar.xz
testing/py-linkedin: new aport
Python API wrapper for linkedin https://github.com/michaelhelmick/linkedin/
Diffstat (limited to 'testing/py-linkedin')
-rw-r--r--testing/py-linkedin/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-linkedin/APKBUILD b/testing/py-linkedin/APKBUILD
new file mode 100644
index 000000000..3f2565d2b
--- /dev/null
+++ b/testing/py-linkedin/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-linkedin
+_pkgname=linkedin
+pkgver=0.1.5
+pkgrel=0
+pkgdesc="Python API wrapper for linkedin"
+url="https://github.com/michaelhelmick/linkedin/"
+arch="noarch"
+license="MIT"
+depends="python py-simplejson py-oauth2 py-httplib2 py-oauth2"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="ef21edd3c1ffc9aaca53ce71faa8a1c3 linkedin-0.1.5.tar.gz"
+sha256sums="e56760a6506a111eb66cd96b46e1971130d2249f2a0f3b594d12fab0013cc4b4 linkedin-0.1.5.tar.gz"
+sha512sums="d007988ce130d7fc8f2b6338f0028af67cae71426648c3164f3f262b91ffa1f035af9d6a75ca8496689d6bfcb6663f1eb27781be7deb9d861a46e813286538c4 linkedin-0.1.5.tar.gz"