summaryrefslogtreecommitdiffstats
path: root/testing/py-markdown
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-03-03 20:34:48 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-03-04 09:50:18 +0000
commit9633c066adcd4b651827d87d7a06fcb74d9ed4dd (patch)
treec23386fe3ebabcb71c80da307ec6f870ec811c1e /testing/py-markdown
parentde7f4b0b9676cb37db31c61575484f5daf6dabc2 (diff)
downloadaports-9633c066adcd4b651827d87d7a06fcb74d9ed4dd.tar.bz2
aports-9633c066adcd4b651827d87d7a06fcb74d9ed4dd.tar.xz
testing/py-markdown: new aport
This is a Python implementation of John Gruber's Markdown. It is almost completely compliant with the reference implementation, though there are a few very minor differences. Website: http://pythonhosted.org/Markdown/
Diffstat (limited to 'testing/py-markdown')
-rw-r--r--testing/py-markdown/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-markdown/APKBUILD b/testing/py-markdown/APKBUILD
new file mode 100644
index 000000000..71bbd6b3e
--- /dev/null
+++ b/testing/py-markdown/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-markdown
+_pkgname=Markdown
+pkgver=2.2.1
+pkgrel=0
+pkgdesc="A Python implementation of Markdown"
+url="http://pythonhosted.org/Markdown/"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="9e002c8051fb346cae75060f3302048a Markdown-2.2.1.tar.gz"
+sha256sums="f8b9a1efceab71afe9336a7c456fde36bfb0f505fb664ebb7f3dd44eddab44b6 Markdown-2.2.1.tar.gz"
+sha512sums="aa975a9d015e3e1320f35381c7e83e1f355222a3c0096e65ce4f1a1fa253fe0e3389ce1b3786b1cf40f4160863ede39d1081c655efe1c24132a766f02418fd61 Markdown-2.2.1.tar.gz"