summaryrefslogtreecommitdiffstats
path: root/testing/py-phpserialize
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-08-21 21:29:51 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2014-08-23 10:29:07 +0000
commit9a106663e799c6582ec258e320ee6b21d0be7258 (patch)
tree990f4b0af61a98f089f3d16562027bcd5add21dc /testing/py-phpserialize
parent2e2bfc43ec0e502ddaad99f1442341db45d01bc8 (diff)
downloadaports-9a106663e799c6582ec258e320ee6b21d0be7258.tar.bz2
aports-9a106663e799c6582ec258e320ee6b21d0be7258.tar.xz
testing/py-phpserialize: new aport
A PHP serializer implementation for Python https://github.com/mitsuhiko/phpserialize
Diffstat (limited to 'testing/py-phpserialize')
-rw-r--r--testing/py-phpserialize/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-phpserialize/APKBUILD b/testing/py-phpserialize/APKBUILD
new file mode 100644
index 000000000..2722d702b
--- /dev/null
+++ b/testing/py-phpserialize/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-phpserialize
+_pkgname=phpserialize
+pkgver=1.3
+pkgrel=0
+pkgdesc="A PHP serializer implementation for Python"
+url="https://github.com/mitsuhiko/phpserialize"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="cbf88a62e04135e3be3c7fe412525b8b phpserialize-1.3.tar.gz"
+sha256sums="bf672d312d203d09a84c26366fab8f438a3ffb355c407e69974b7ef2d39a0fa7 phpserialize-1.3.tar.gz"
+sha512sums="8b5cabbccb4e336912c376ac70b4c4b7d192f22660d5f679caeb583e9f47f45b933c19683bed003a88b86f59099bcd63a576fd72ce67ea6573587ffb3fa9e5a0 phpserialize-1.3.tar.gz"