summaryrefslogtreecommitdiffstats
path: root/testing/py-stdnum
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-07 21:13:13 +0000
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-09-08 14:36:47 +0200
commit20634c818b579e0f68bd830277d5fb20672df582 (patch)
tree4057c67c8c0d200f9e4cd379af7438760a1ab115 /testing/py-stdnum
parent8b4484a33c9b98c2b0a3add5d578fab9f2816699 (diff)
downloadaports-20634c818b579e0f68bd830277d5fb20672df582.tar.bz2
aports-20634c818b579e0f68bd830277d5fb20672df582.tar.xz
testing/py-stdnum: new aport
A Python module to handle standardized numbers and codes http://arthurdejong.org/python-stdnum/
Diffstat (limited to 'testing/py-stdnum')
-rw-r--r--testing/py-stdnum/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-stdnum/APKBUILD b/testing/py-stdnum/APKBUILD
new file mode 100644
index 000000000..64644ea91
--- /dev/null
+++ b/testing/py-stdnum/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-stdnum
+_pkgname=python-stdnum
+pkgver=0.8.1
+pkgrel=0
+pkgdesc="A Python module to handle standardized numbers and codes"
+url="http://arthurdejong.org/python-stdnum/"
+arch="noarch"
+license="LGPL2+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="fd2d8f12055d4a133fe480ec7f20fa94 python-stdnum-0.8.1.tar.gz"
+sha256sums="41bac7de44ac84bc23325070e931e187fb00bfb6b93e0f4fbecc8736bd31b1d2 python-stdnum-0.8.1.tar.gz"
+sha512sums="c3aa3179b6c27ca88ad8a39c086f8305d3406f79e29ea06656c1a5caf2c78a0fac4fa04bb663bb83f2c8e105cf156e9e421854b9b4c16b2cc18825c4f0ae1028 python-stdnum-0.8.1.tar.gz"