summaryrefslogtreecommitdiffstats
path: root/testing/qca
diff options
context:
space:
mode:
authorLinux User <se@alpine-desktop.my.domain>2014-10-16 19:52:25 +0400
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-17 13:52:16 +0000
commit9085b73f09d41af164193a3e0b5e22fcce80d503 (patch)
tree5d2e5fa503bf2540ddeed992a4aba407ffa24649 /testing/qca
parent276617c77708f50d68ba9b4c87a866399ddd7250 (diff)
downloadaports-9085b73f09d41af164193a3e0b5e22fcce80d503.tar.bz2
aports-9085b73f09d41af164193a3e0b5e22fcce80d503.tar.xz
Added KDE core packages
Diffstat (limited to 'testing/qca')
-rw-r--r--testing/qca/APKBUILD10
-rw-r--r--testing/qca/secmem.patch11
2 files changed, 19 insertions, 2 deletions
diff --git a/testing/qca/APKBUILD b/testing/qca/APKBUILD
index b11415ffc..9d0644dbf 100644
--- a/testing/qca/APKBUILD
+++ b/testing/qca/APKBUILD
@@ -12,7 +12,8 @@ depends_dev="qt-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://delta.affinix.com/download/qca/2.0/qca-$pkgver.tar.bz2"
+source="http://delta.affinix.com/download/qca/2.0/qca-$pkgver.tar.bz2
+ secmem.patch"
_builddir="$srcdir"/qca-$pkgver
prepare() {
@@ -37,4 +38,9 @@ package() {
make INSTALL_ROOT="$pkgdir" install || return 1
}
-md5sums="fc15bd4da22b8096c51fcfe52d2fa309 qca-2.0.3.tar.bz2"
+md5sums="fc15bd4da22b8096c51fcfe52d2fa309 qca-2.0.3.tar.bz2
+53f5a927d6d654c5a82e106834e79985 secmem.patch"
+sha256sums="8da20c89f390954fdcfcd3c4deef379213ddb5ae9d6b5e0c917d23f5e474895f qca-2.0.3.tar.bz2
+0bbe520dfe5f7d3114ed4b6cc772b0250472674b86415fe1d1aeaccaa7271257 secmem.patch"
+sha512sums="c1120ffb373e294fbcc76e21dc2f503ebd3398b26d0ffa7ab7ee3a3e1a4228159358b59c2673ac4a1c2363771e61da54a5080b201c65d586ceda2e3b2facc1bb qca-2.0.3.tar.bz2
+a06519a055af21d53bed65d90e31089d3c1e3fdf2459c6c52c394678cb0775a5f262728617eecbbd9e8e7f0340c7aa9326a8eb030de6214e24d7590032db5444 secmem.patch"
diff --git a/testing/qca/secmem.patch b/testing/qca/secmem.patch
new file mode 100644
index 000000000..8f2306f7d
--- /dev/null
+++ b/testing/qca/secmem.patch
@@ -0,0 +1,11 @@
+--- a/src/botantools/botan/botan/secmem.h
++++ b/src/botantools/botan/botan/secmem.h
+@@ -214,7 +214,7 @@
+
+ SecureVector(u32bit n = 0) { MemoryRegion<T>::init(true, n); }
+ SecureVector(const T in[], u32bit n)
+- { MemoryRegion<T>::init(true); set(in, n); }
++ { MemoryRegion<T>::init(true); this->set(in, n); }
+ SecureVector(const MemoryRegion<T>& in)
+ { MemoryRegion<T>::init(true); set(in); }
+ SecureVector(const MemoryRegion<T>& in1, const MemoryRegion<T>& in2)