summaryrefslogtreecommitdiffstats
path: root/testing/spice-vdagent
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-06-11 09:05:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-06-11 09:06:46 +0000
commitc8b0149c79cc4bbde08db53f5ce77cf983fb9681 (patch)
tree46abcfa26bac61cbe6e6f57f66500b2624552483 /testing/spice-vdagent
parent33028001f5cf3741dc358ec110d0cb84f1580830 (diff)
downloadaports-c8b0149c79cc4bbde08db53f5ce77cf983fb9681.tar.bz2
aports-c8b0149c79cc4bbde08db53f5ce77cf983fb9681.tar.xz
testing/spice-vdagent: new aport
Agent for Spice guests http://spice-space.org/
Diffstat (limited to 'testing/spice-vdagent')
-rw-r--r--testing/spice-vdagent/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/spice-vdagent/APKBUILD b/testing/spice-vdagent/APKBUILD
new file mode 100644
index 000000000..feb52cffa
--- /dev/null
+++ b/testing/spice-vdagent/APKBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=spice-vdagent
+pkgver=0.15.0
+pkgrel=0
+pkgdesc="Agent for Spice guests"
+url="http://spice-space.org/"
+arch="all"
+license="GPLv3+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev glib-dev spice-protocol libpciaccess-dev
+ libxrandr-dev libxinerama-dev libxfixes-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://spice-space.org/download/releases/spice-vdagent-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/spice-vdagent-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="2919ac7a4195b0b4b2588fae90a9241c spice-vdagent-0.15.0.tar.bz2"
+sha256sums="5bae1747307c2f4195f6de97639391be7c6be6c5673fdcc9febed6faca22bd34 spice-vdagent-0.15.0.tar.bz2"
+sha512sums="7d3bdeca2a8a5a63f817c8b0c1c46508e3238e0d2f3a018e44ffa4c7a2b7d0e82b0a2c37a6f35c59fcb23d89de82312edb689dc1de6fdf659004e640b900f436 spice-vdagent-0.15.0.tar.bz2"