summaryrefslogtreecommitdiffstats
path: root/testing/texlive
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-02-12 13:45:29 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2015-02-12 13:45:29 +0000
commitf9f2e4330bd518df2316527318f21ada2d026988 (patch)
treeb6a0832da09a3ba18273d57532dbf3bd162f01f6 /testing/texlive
parentdf64aa9f195fe39c90456b2522e0d7fe551e937f (diff)
downloadaports-f9f2e4330bd518df2316527318f21ada2d026988.tar.bz2
aports-f9f2e4330bd518df2316527318f21ada2d026988.tar.xz
testing/texlive: new aport
This is a minimal src build. Dont expect it to work at all.
Diffstat (limited to 'testing/texlive')
-rw-r--r--testing/texlive/APKBUILD104
-rw-r--r--testing/texlive/musl-fixes.patch14
2 files changed, 118 insertions, 0 deletions
diff --git a/testing/texlive/APKBUILD b/testing/texlive/APKBUILD
new file mode 100644
index 000000000..0d631675b
--- /dev/null
+++ b/testing/texlive/APKBUILD
@@ -0,0 +1,104 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=texlive
+pkgver=20140525
+pkgrel=0
+pkgdesc="A complete TeX distribution"
+url="http://tug.org/texlive/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="freetype-dev libpng-dev poppler-dev icu-dev harfbuzz-dev
+ cairo-dev pixman-dev zziplib-dev libpaper-dev graphite2-dev
+ libxmu-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="ftp://tug.org/texlive/historic/2014/texlive-$pkgver-source.tar.xz
+ musl-fixes.patch"
+
+_builddir="$srcdir"/texlive-$pkgver-source
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ mkdir -p $_builddir/build && cd $_builddir/build
+ ../configure -C \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-system-freetype2 \
+ --with-system-zlib \
+ --with-system-libpng \
+ --with-system-xpdf \
+ --with-system-poppler \
+ --with-system-icu \
+ --with-system-harfbuzz \
+ --with-system-icu \
+ --with-system-graphite2 \
+ --with-system-cairo \
+ --with-system-pixman \
+ --with-system-zziplib \
+ --with-system-libpaper \
+ --without-texinfo \
+ --disable-dialog \
+ --disable-multiplatform \
+ --enable-epsfwin \
+ --enable-mftalkwin \
+ --enable-regiswin \
+ --enable-tektronixwin \
+ --enable-unitermwin \
+ --with-ps=gs \
+ --disable-psutils \
+ --disable-t1utils \
+ --enable-ipc \
+ --disable-biber \
+ --disable-bibtex-x \
+ --disable-dvipng \
+ --disable-dvipsk \
+ --disable-chktex \
+ --disable-lcdf-typetools \
+ --disable-pdfopen \
+ --disable-ps2eps \
+ --disable-ps2pkm \
+ --disable-detex \
+ --disable-ttf2pk2 \
+ --disable-tex4htk \
+ --disable-cjkutils \
+ --disable-xdvik \
+ --disable-xindy \
+ --enable-luatex \
+ --disable-dvi2tty \
+ --disable-dvisvgm \
+ --disable-vlna \
+ --enable-shared \
+ --disable-native-texlive-build \
+ --disable-largefile \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="09ee265ff51637827559affc7304078c texlive-20140525-source.tar.xz
+c5a1569dac61bf0b7fbf26eebe987e4e musl-fixes.patch"
+sha256sums="08bb4eb02923ac65ce1183612c6b64da185904f26a1660f5ca4f902d055795be texlive-20140525-source.tar.xz
+10a80468ec4c6f5462f1a1b7751dcd5ebfb06c156d6e1d9b06581adfcbf18d5a musl-fixes.patch"
+sha512sums="09169af15d806abd721e55ffc20ed684c0a7ad60783272d49fabfe9c88857c4abd15b60f30e3f5511ceda1982fdc1d33db8265f97e374bfa5b250dbb5612f8ad texlive-20140525-source.tar.xz
+7bdbb02e733314275b88cdabb21b3f1959756d2291c9685891430681944d898cd59cac501a613a3f2dd3e2f946a1b156b215ae86f5643c3ac769e376e2123d17 musl-fixes.patch"
diff --git a/testing/texlive/musl-fixes.patch b/testing/texlive/musl-fixes.patch
new file mode 100644
index 000000000..694e55467
--- /dev/null
+++ b/testing/texlive/musl-fixes.patch
@@ -0,0 +1,14 @@
+--- a/utils/pmx/pmx-2.7.0/libf2c/sysdep1.h.orig
++++ b/utils/pmx/pmx-2.7.0/libf2c/sysdep1.h
+@@ -10,7 +10,11 @@
+
+ #ifdef __linux__
+ #define USE_LARGEFILE
++#ifdef __GLIBC__
+ #define OFF_T __off64_t
++#else
++#define OFF_T off_t
++#endif
+ #endif
+
+ #ifdef _AIX43