summaryrefslogtreecommitdiffstats
path: root/testing/thttpd
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-22 21:35:57 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-22 21:35:57 +0200
commit99ee0118807872fc2b28b1379fcdf5ed71e6d52a (patch)
treee3ddacc2f40ecd7f41576f49ee3bb7edcbfd1492 /testing/thttpd
parent9dc9b2ae03b8d32d4a6cb9fa74203b56184838bd (diff)
downloadaports-99ee0118807872fc2b28b1379fcdf5ed71e6d52a.tar.bz2
aports-99ee0118807872fc2b28b1379fcdf5ed71e6d52a.tar.xz
testing/thttpd: add missing man dir
Diffstat (limited to 'testing/thttpd')
-rw-r--r--testing/thttpd/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/testing/thttpd/APKBUILD b/testing/thttpd/APKBUILD
index 220343234..3c80b7a9c 100644
--- a/testing/thttpd/APKBUILD
+++ b/testing/thttpd/APKBUILD
@@ -40,19 +40,21 @@ build() {
./configure --prefix=/usr --mandir=/usr/share/man
sed -e 's/^CFLAGS =/CFLAGS +=/' \
-e '/^STATICFLAG =/c STATICFLAG =' \
- -i Makefile */Makefile
+ -i Makefile */Makefile || return 1
- make
+ make || return 1
}
package() {
cd "$_builddir"
+
+ mkdir -p $pkgdir/usr/share/man/man1
make \
BINDIR="$pkgdir"/usr/sbin \
WEBDIR="$pkgdir"/var/www/http \
MANDIR="$pkgdir"/usr/share/man \
- WEBGROUP=root install
+ WEBGROUP=root install || return 1
rm -rf "$pkgdir"/var/www/http/*
@@ -67,7 +69,8 @@ package() {
install -d "$pkgdir"/var/log/thttpd
install -d "$pkgdir"/usr/share/licenses/"$pkgname"
- head -n 26 thttpd.c > "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ head -n 26 thttpd.c > \
+ "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE || return 1
}
md5sums="156b249b3b0bcd48b06badd2db0d56c5 thttpd-2.25b.tar.gz