summaryrefslogtreecommitdiffstats
path: root/testing/tint2
diff options
context:
space:
mode:
authorMarian <mari.hahn@wwu.de>2014-10-04 12:14:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-06 15:02:38 +0000
commitca9ff508382dcd1af726f956f3ef2766c43e88da (patch)
tree6374c00e0f9f2b95acaaa99695e7f1d305f8cb39 /testing/tint2
parent21dbf20f52bed1e9ca112acc550013be68e5c17b (diff)
downloadaports-ca9ff508382dcd1af726f956f3ef2766c43e88da.tar.bz2
aports-ca9ff508382dcd1af726f956f3ef2766c43e88da.tar.xz
Added package for tint2 in testing
tint2 is a lightweight panel which plays nicely together with openbox.
Diffstat (limited to 'testing/tint2')
-rw-r--r--testing/tint2/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/tint2/APKBUILD b/testing/tint2/APKBUILD
new file mode 100644
index 000000000..e33c105c0
--- /dev/null
+++ b/testing/tint2/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: mari (dot) hahn (at) wwu (dot) de
+pkgname=tint2
+pkgver=0.11
+pkgrel=0
+pkgdesc="tint2 is a simple panel/taskbar unintrusive and light"
+url="http://code.google.com/p/tint2/"
+arch="all"
+license="GPL2"
+depends="imlib2 glib pango cairo libxcomposite libxdamage libxinerama libxrandr gtk+"
+depends_dev="cmake imlib2-dev glib-dev pango-dev cairo-dev libxcomposite-dev libxdamage-dev libxinerama-dev libxrandr-dev gtk+-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://tint2.googlecode.com/files/${pkgname}-${pkgver}.tar.bz2"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr . || return 1
+ make || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="6fc5731e7425125fa84a2add5cef4bff tint2-0.11.tar.bz2"
+sha256sums="fe106e6a6057d2631abddde9f82d3fd4fb1985c4fb93f10d3886417a9e22471d tint2-0.11.tar.bz2"
+sha512sums="db88c17780d24b82badbedbce4518d736dfcb2a730ff500bcb36f2b32f65271c2424f0c2a34981f9d3af033b84252db0c8217e2dd7ca57f9a0eadbc98796115c tint2-0.11.tar.bz2"