summaryrefslogtreecommitdiffstats
path: root/testing/triggerhappy
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-02-28 12:57:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-02-28 12:59:39 +0000
commit540556b311c1f642969eb9e1259072696c8ee99f (patch)
tree43b7fa368224b88b6ffba538d3bcbbef471bb22e /testing/triggerhappy
parent8ac336d8c9b889ad571754b39b3f9da5e07a826b (diff)
downloadaports-540556b311c1f642969eb9e1259072696c8ee99f.tar.bz2
aports-540556b311c1f642969eb9e1259072696c8ee99f.tar.xz
testing/triggerhappy: new aport
A lightweight hotkey daemon https://github.com/wertarbyte/triggerhappy
Diffstat (limited to 'testing/triggerhappy')
-rw-r--r--testing/triggerhappy/APKBUILD59
-rw-r--r--testing/triggerhappy/triggerhappy.confd2
-rw-r--r--testing/triggerhappy/triggerhappy.initd10
3 files changed, 71 insertions, 0 deletions
diff --git a/testing/triggerhappy/APKBUILD b/testing/triggerhappy/APKBUILD
new file mode 100644
index 000000000..f61b9b616
--- /dev/null
+++ b/testing/triggerhappy/APKBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=triggerhappy
+pkgver=0.3.4
+pkgrel=0
+pkgdesc="A lightweight hotkey daemon"
+url="https://github.com/wertarbyte/triggerhappy"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="triggerhappy-$pkgver.tar.gz::https://github.com/wertarbyte/triggerhappy/archive/release/$pkgver.tar.gz
+ triggerhappy.initd
+ triggerhappy.confd
+ "
+
+_builddir="$srcdir"/triggerhappy-release-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+ install -D udev/triggerhappy-udev.rules \
+ "$pkgdir"/lib/udev/rules.d/50-triggerhappy.rules \
+ || return 1
+ install -d "$pkgdir"/etc/triggerhappy/triggers.d || return 1
+ install triggerhappy.conf.examples \
+ "$pkgdir"/etc/triggerhappy/triggerhappy.conf || return 1
+ install -Dm755 "$srcdir"/triggerhappy.initd \
+ "$pkgdir"/etc/init.d/triggerhappy || return 1
+ install -Dm644 "$srcdir"/triggerhappy.confd \
+ "$pkgdir"/etc/conf.d/triggerhappy || return 1
+}
+
+md5sums="9719903899b3082e75a7ff6e9c00752d triggerhappy-0.3.4.tar.gz
+902daa19d3315296df89c49904cfeca2 triggerhappy.initd
+b96c7efb0c27a2d598ebab9cb8dd5dd9 triggerhappy.confd"
+sha256sums="68001858df715527326850940a71690fda9d159ac73bed4a580fb7d2ffd61c83 triggerhappy-0.3.4.tar.gz
+d54f4e03f0ace48175af502019cad78ebfa3175ac1ab7b3f1a516f74a11be1e0 triggerhappy.initd
+1601b34ed30ec11293a353937669d030d811357fa2e0f5eb7ff04874daf91702 triggerhappy.confd"
+sha512sums="cf08554a41019019c1142368273dc781c840bb9de81b9a386b4debd34f37816bfe516077f7192779822aa5662b3fadd76a6ff141e7c038b65dd7f51e92135e4c triggerhappy-0.3.4.tar.gz
+62eaa739d6c097d5d3b505087dffad28836ac05ed8622152264defda603eb0181d58d8d0c57641adac06e44f3546198241552a3672d6deec136f019f1afa039b triggerhappy.initd
+5f31b9736e8ee8a7c8125dd5c14c4cdf515a6d57c36d04b9b1949cdb6150f25ef264ed8ee5e31f0d62de12db151df5aec9a325ff5d5b5ba0b3b7105c76cd07a0 triggerhappy.confd"
diff --git a/testing/triggerhappy/triggerhappy.confd b/testing/triggerhappy/triggerhappy.confd
new file mode 100644
index 000000000..f449481e5
--- /dev/null
+++ b/testing/triggerhappy/triggerhappy.confd
@@ -0,0 +1,2 @@
+# specify input device(s)
+#devices="/dev/input/event0"
diff --git a/testing/triggerhappy/triggerhappy.initd b/testing/triggerhappy/triggerhappy.initd
new file mode 100644
index 000000000..18b073cfb
--- /dev/null
+++ b/testing/triggerhappy/triggerhappy.initd
@@ -0,0 +1,10 @@
+#!/sbin/runscript
+
+: ${socket:=/var/run/thd.socket}
+: ${triggers:=/etc/triggerhappy/triggers.d}
+
+command=/usr/sbin/thd
+pidfile=/var/run/thd.pid
+command_args="--daemon --socket $socket --triggers $triggers $devices --pidfile $pidfile"
+
+