summaryrefslogtreecommitdiffstats
path: root/testing/weplab
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-06-25 16:44:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-27 08:24:07 +0000
commit50c309f672c325517bda70483f9a688b95a565a4 (patch)
treeb10f6c783a1cc583aa2b6c6591f63c7a290ab26b /testing/weplab
parentc13458e887b637acb401b221cba44a8ac292b11a (diff)
downloadaports-50c309f672c325517bda70483f9a688b95a565a4.tar.bz2
aports-50c309f672c325517bda70483f9a688b95a565a4.tar.xz
Initial APKBUILD for Alpine Linux
Diffstat (limited to 'testing/weplab')
-rw-r--r--testing/weplab/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/weplab/APKBUILD b/testing/weplab/APKBUILD
new file mode 100644
index 000000000..9117f53c9
--- /dev/null
+++ b/testing/weplab/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer:
+pkgname=weplab
+pkgver=0.1.5
+pkgrel=0
+pkgdesc="Analyzing WEP encryption security on wireless networks"
+url="http://weplab.sourceforge.net/"
+arch="all"
+license="GPLv2+"
+depends=
+depends_dev="libpcap-dev wireless-tools-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+ install -Dm 644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="713870965447b0b8b7341409968846fb weplab-0.1.5.tar.gz"