summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-05-25 16:44:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-05-25 16:44:59 +0000
commit3cacc3cd9681b20438002cb7a54ef144d8f329c5 (patch)
treef13a2e46bdb8c7f9d1d6ce6a577fad897dd8db40 /testing
parent07f17dd0e833d0e401b72e50f216e7d0c5d6c151 (diff)
downloadaports-3cacc3cd9681b20438002cb7a54ef144d8f329c5.tar.bz2
aports-3cacc3cd9681b20438002cb7a54ef144d8f329c5.tar.xz
main/udisks2: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/udisks2/APKBUILD52
-rw-r--r--testing/udisks2/O_CLOEXEC.patch10
-rw-r--r--testing/udisks2/sys-wait.patch10
-rw-r--r--testing/udisks2/udisks2-root-bound-mount-fix.patch35
4 files changed, 0 insertions, 107 deletions
diff --git a/testing/udisks2/APKBUILD b/testing/udisks2/APKBUILD
deleted file mode 100644
index 9975641ea..000000000
--- a/testing/udisks2/APKBUILD
+++ /dev/null
@@ -1,52 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=udisks2
-pkgver=1.97.0
-pkgrel=0
-pkgdesc="Disk Manager"
-url="http://www.freedesktop.org/wiki/Software/udisks"
-arch="all"
-license="GPLv2+"
-depends=""
-depends_dev="glib-dev gobject-introspection-dev polkit-dev libatasmart-dev
- udev-dev acl-dev"
-makedepends="$depends_dev intltool gtk-doc"
-install=""
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="http://udisks.freedesktop.org/releases/udisks-$pkgver.tar.bz2
- O_CLOEXEC.patch
- sys-wait.patch
- udisks2-root-bound-mount-fix.patch"
-
-_builddir="$srcdir"/udisks-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- rm -f "$pkgdir"/usr/lib/*.la
-}
-
-md5sums="8ae4ef908ab706789e0e2b33d8810877 udisks-1.97.0.tar.bz2
-fd70ee4163c5bfd9bd474c28a2548c46 O_CLOEXEC.patch
-4c7aa82c180c809f565c55325ce9eb20 sys-wait.patch
-11d6256cd2c2aab25e824bf613061925 udisks2-root-bound-mount-fix.patch"
diff --git a/testing/udisks2/O_CLOEXEC.patch b/testing/udisks2/O_CLOEXEC.patch
deleted file mode 100644
index 790fc2d8b..000000000
--- a/testing/udisks2/O_CLOEXEC.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/udiskslinuxblock.c.orig
-+++ ./src/udiskslinuxblock.c
-@@ -24,6 +24,7 @@
- #include <sys/types.h>
- #include <sys/mount.h>
- #include <sys/stat.h>
-+#define __USE_GNU
- #include <fcntl.h>
- #include <pwd.h>
- #include <grp.h>
diff --git a/testing/udisks2/sys-wait.patch b/testing/udisks2/sys-wait.patch
deleted file mode 100644
index 1ac86d50d..000000000
--- a/testing/udisks2/sys-wait.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/udiskslinuxfilesystem.c.orig
-+++ ./src/udiskslinuxfilesystem.c
-@@ -30,6 +30,7 @@
- #include <mntent.h>
- #include <sys/types.h>
- #include <sys/acl.h>
-+#include <sys/wait.h>
- #include <errno.h>
-
- #include <glib/gstdio.h>
diff --git a/testing/udisks2/udisks2-root-bound-mount-fix.patch b/testing/udisks2/udisks2-root-bound-mount-fix.patch
deleted file mode 100644
index 53d711baa..000000000
--- a/testing/udisks2/udisks2-root-bound-mount-fix.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From e0b8ffe3099735fefd64973e6575c67ac0759be2 Mon Sep 17 00:00:00 2001
-From: David Zeuthen <davidz@redhat.com>
-Date: Tue, 15 May 2012 14:17:22 +0000
-Subject: Bug 49842 – Unhandled rootfs on bind mount
-
-Don't ignore a mount just because if a subtree of the filesystem is
-mounted. Because if we do this, we may wrongly conclude the device is
-not mounted at all, which then means that it's visible in the desktop
-UI and subject to automounting.
-
-In the future, we may want a "a(ss) MountPointsFull" property that in
-addition to the mount point also contains the subtree that is mounted
-at said mountpoint.
-
-https://bugs.freedesktop.org/show_bug.cgi?id=49842
-
-Signed-off-by: David Zeuthen <davidz@redhat.com>
----
-diff --git a/src/udisksmountmonitor.c b/src/udisksmountmonitor.c
-index 43adaa5..36e1476 100644
---- a/src/udisksmountmonitor.c
-+++ b/src/udisksmountmonitor.c
-@@ -433,10 +433,6 @@ udisks_mount_monitor_get_mountinfo (UDisksMountMonitor *monitor,
- continue;
- }
-
-- /* ignore mounts where only a subtree of a filesystem is mounted */
-- if (g_strcmp0 (encoded_root, "/") != 0)
-- continue;
--
- /* Temporary work-around for btrfs, see
- *
- * https://bugzilla.redhat.com/show_bug.cgi?id=495152#c31
---
-cgit v0.9.0.2-2-gbebe