summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMika Havela <mika.havela@gmail.com>2010-05-05 07:46:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-13 07:47:07 +0000
commit4411ab47a361bb2483e368022c0b103b6e09d948 (patch)
treefa3cf3b78d3d4861e4b0089fbbe25e109e88c728 /testing
parent45b7b258918e56c528cd56a4cef134f4a79ffd0f (diff)
downloadaports-4411ab47a361bb2483e368022c0b103b6e09d948.tar.bz2
aports-4411ab47a361bb2483e368022c0b103b6e09d948.tar.xz
testing/perl-yaml-syck: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-yaml-syck/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/perl-yaml-syck/APKBUILD b/testing/perl-yaml-syck/APKBUILD
new file mode 100644
index 000000000..d1c628054
--- /dev/null
+++ b/testing/perl-yaml-syck/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+# Maintainer: Mika Havela <mika.havela@gmail.com>
+pkgname=perl-yaml-syck
+_realname=YAML-Syck
+pkgver=1.07
+pkgrel=0
+pkgdesc="Perl - Fast, lightweight YAML loader and dumper"
+url="http://search.cpan.org/~audreyt/$_realname-$pkgver/"
+license="Artistic GPL"
+depends="perl"
+makedepends="perl-dev"
+install=
+#subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/A/AU/AUDREYT/$_realname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_realname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+md5sums="410ef7e24185de2a04390e0543876cad YAML-Syck-1.07.tar.gz"