summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2013-08-30 14:38:57 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2013-08-30 14:39:27 +0000
commit4ca5b41c394977d681a4cf0c85dce351180f162a (patch)
tree2724c644ef40fa9889bbf60ef043fb69046f6b87 /testing
parent1605e4d90d572350c0fa2338806b700b41de31cb (diff)
downloadaports-4ca5b41c394977d681a4cf0c85dce351180f162a.tar.bz2
aports-4ca5b41c394977d681a4cf0c85dce351180f162a.tar.xz
testing/racktables: create secret.php
Diffstat (limited to 'testing')
-rw-r--r--testing/racktables/APKBUILD5
-rwxr-xr-xtesting/racktables/racktables.post-install4
2 files changed, 6 insertions, 3 deletions
diff --git a/testing/racktables/APKBUILD b/testing/racktables/APKBUILD
index 247354e15..f515ab9f2 100644
--- a/testing/racktables/APKBUILD
+++ b/testing/racktables/APKBUILD
@@ -3,7 +3,7 @@
pkgname=racktables
_realname=RackTables
pkgver=0.20.5
-pkgrel=0
+pkgrel=1
pkgdesc="Server room asset management"
url="http://racktables.org"
arch="noarch"
@@ -39,7 +39,8 @@ package() {
export docdir="/usr/share/doc/RackTables"
make DESTDIR="${pkgdir}" install
make DESTDIR="${pkgdir}" install-docs
- mkdir -p "$pkgdir/etc/racktables"
+ mkdir -p "$pkgdir"/etc/racktables
+ touch "$pkgdir"/etc/racktables/secret.php
install -D -m644 "$srcdir"/index-racktables.php \
"$pkgdir"/usr/share/webapps/RackTables/wwwroot/index-racktables.php
}
diff --git a/testing/racktables/racktables.post-install b/testing/racktables/racktables.post-install
index 222c750ff..5b7905cf2 100755
--- a/testing/racktables/racktables.post-install
+++ b/testing/racktables/racktables.post-install
@@ -4,4 +4,6 @@ echo "* Please give ownership to the web server user, the following directories:
echo "*"
echo "* /etc/racktables"
echo "*"
-
+echo -e "* Symlink /usr/share/webapps/RackTables/index-racktables.php\n\
+ to your webserver directory"
+echo "*"