summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2015-05-29 09:01:12 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-05-29 09:01:18 +0000
commit5f6a5c1f302cfcb9e7c49cdbb9c8ff47ca70b000 (patch)
tree6d2aca4b9a8e3491a1e9180828699639da4966cd /testing
parent8860969eb7d484dc6f2543c6b6c7a5750f4b1dcf (diff)
downloadaports-5f6a5c1f302cfcb9e7c49cdbb9c8ff47ca70b000.tar.bz2
aports-5f6a5c1f302cfcb9e7c49cdbb9c8ff47ca70b000.tar.xz
testing/ruby-hoe: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/ruby-hoe/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/ruby-hoe/APKBUILD b/testing/ruby-hoe/APKBUILD
new file mode 100644
index 000000000..22c5b4563
--- /dev/null
+++ b/testing/ruby-hoe/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+
+_gemname=hoe
+pkgname=ruby-$_gemname
+pkgver=3.13.1
+pkgrel=0
+pkgdesc="Hoe is a rake/rubygems helper for project Rakefiles"
+arch="noarch"
+url="http://www.zenspider.com/projects/hoe.html"
+license="MIT"
+depends="ruby"
+depends_dev=
+makedepends="$depends_dev"
+source="https://rubygems.org/downloads/$_gemname-$pkgver.gem"
+_builddir="$srcdir"/$_gemname-$pkgver
+build() {
+ mkdir -p "$_builddir" || return 1
+ export _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ gem install $_gemname -v $pkgver -i "$_builddir"$_gemdir \
+ --ignore-dependencies \
+ --verbose \
+ --no-rdoc \
+ --no-ri \
+ || return 1
+ rm -rf "$pkgdir"/$_gemdir/cache \
+ "$pkgdir"/$_geminstdir/ext \
+ "$pkgdir"/$_geminstdir/.require_paths
+}
+
+package() {
+ mkdir -p "$pkgdir" || return 1
+ cp -ra "$_builddir"/* "$pkgdir"/ || return 1
+}
+
+md5sums="739d4ede50ba5bf9fabb03cef59c3737 hoe-3.13.1.gem"
+sha256sums="18414316a39bc828b4b943aed6817774ce23642fa6b51450b25ae596e7084cd5 hoe-3.13.1.gem"
+sha512sums="9962f7cdf3179e5073c63983e5ee20926399c17769d1588292427d1bb7f765d3444fbefa57edaa610dc053a5bd3bd0ba16bf627ca0713e88e4b7f039435b127e hoe-3.13.1.gem"