summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2012-02-07 13:43:36 +0200
committerTimo Teräs <timo.teras@iki.fi>2012-02-07 13:45:02 +0200
commit6a7a6ebb1a5f0f9c929cebbf4a62ffac45450617 (patch)
tree6608dca99573af548f4d75db0c1d3dab5eebb56c /testing
parent35ced06b6b53edd7871b14b2121f2599973576a1 (diff)
downloadaports-6a7a6ebb1a5f0f9c929cebbf4a62ffac45450617.tar.bz2
aports-6a7a6ebb1a5f0f9c929cebbf4a62ffac45450617.tar.xz
testing/firefox: fix jemalloc properly (fixes #995)
* fix patch "xulrunner: malloc_usable_size" properly * remove debug info * use system sqlite
Diffstat (limited to 'testing')
-rw-r--r--testing/xulrunner/0004-xulrunner-malloc_usable_size.patch55
-rw-r--r--testing/xulrunner/APKBUILD11
-rw-r--r--testing/xulrunner/mozconfig1
3 files changed, 37 insertions, 30 deletions
diff --git a/testing/xulrunner/0004-xulrunner-malloc_usable_size.patch b/testing/xulrunner/0004-xulrunner-malloc_usable_size.patch
index aae416c7d..986b183ec 100644
--- a/testing/xulrunner/0004-xulrunner-malloc_usable_size.patch
+++ b/testing/xulrunner/0004-xulrunner-malloc_usable_size.patch
@@ -1,25 +1,34 @@
-From a2a15c826a5e1743ba71288543b9e144603fba26 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 25 Nov 2011 08:40:53 +0000
-Subject: [PATCH 4/4] xulrunner: malloc_usable_size
+From: Timo Teräs <timo.teras@iki.fi>
----
- memory/mozalloc/mozalloc.cpp | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/memory/mozalloc/mozalloc.cpp b/memory/mozalloc/mozalloc.cpp
-index 58e5192..500c651 100644
---- a/memory/mozalloc/mozalloc.cpp
-+++ b/memory/mozalloc/mozalloc.cpp
-@@ -267,7 +267,7 @@ moz_malloc_usable_size(void *ptr)
- #if defined(XP_MACOSX)
- return malloc_size(ptr);
- #elif defined(MOZ_MEMORY)
-- return malloc_usable_size(ptr);
-+ return 0;
- #elif defined(XP_WIN)
- return _msize(ptr);
- #else
---
-1.7.7.4
+malloc_usable_size is not defined on uclibc, so workaround
+that in jemalloc. Fix mozalloc linking.
+--- mozilla-release-old/memory/jemalloc/jemalloc.h
++++ mozilla-release/memory/jemalloc/jemalloc.h
+@@ -75,8 +75,12 @@
+ /* Linux has memalign and malloc_usable_size */
+ #if !defined(MOZ_MEMORY_LINUX)
+ void *memalign(size_t alignment, size_t size);
+-size_t malloc_usable_size(const void *ptr);
+ #endif /* MOZ_MEMORY_LINUX */
++
++#include <features.h>
++#if defined(__UCLIBC__) || !defined(MOZ_MEMORY_LINUX)
++size_t malloc_usable_size(const void *ptr);
++#endif
+
+ void jemalloc_stats(jemalloc_stats_t *stats);
+
+--- mozilla-release-old/memory/mozalloc/Makefile.in
++++ mozilla-release/memory/mozalloc/Makefile.in
+@@ -43,6 +43,10 @@
+
+ include $(DEPTH)/config/autoconf.mk
+
++ifdef MOZ_MEMORY
++SHARED_LIBRARY_LIBS = $(call EXPAND_LIBNAME_PATH,jemalloc,../jemalloc)
++endif
++
+ VISIBILITY_FLAGS=
+ STL_FLAGS =
+ ifdef _MSC_VER
diff --git a/testing/xulrunner/APKBUILD b/testing/xulrunner/APKBUILD
index 5304c8d08..e5954846f 100644
--- a/testing/xulrunner/APKBUILD
+++ b/testing/xulrunner/APKBUILD
@@ -3,7 +3,7 @@
pkgname=xulrunner
pkgver=10.0
_ffoxver=10.0
-pkgrel=3
+pkgrel=4
pkgdesc="runtime environment for xul-based applications"
url="http://developer.mozilla.org/en/XULRunner"
arch="all"
@@ -40,7 +40,7 @@ makedepends="$depends_dev
automake
libtool"
install=""
-options="!strip"
+options=""
subpackages="$pkgname-dev"
# http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/${pkgver}/source/${pkgname}-${pkgver}.source.tar.bz2
source="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}/source/firefox-${_ffoxver}.source.tar.bz2
@@ -65,8 +65,6 @@ prepare() {
done
cp "${srcdir}/mozconfig" .mozconfig
- echo "ac_add_options --enable-debug-symbols" >> .mozconfig
- echo "ac_add_options --disable-install-strip" >>.mozconfig
}
build() {
@@ -78,7 +76,6 @@ build() {
unset CXXFLAGS
make -j1 -f client.mk build \
- STRIP=/bin/true \
MOZ_MAKE_FLAGS="$MAKEFLAGS" || return 1
}
@@ -108,8 +105,8 @@ dev() {
}
md5sums="13c61203ccfa583e5a54b4dc22f41233 firefox-10.0.source.tar.bz2
-45a82169a616b673e67bf52e980d298b mozconfig
+b0f7d491bc800b69ec718667a4b08acb mozconfig
1867db217d10722675c88b655db8c2d7 0002-Use-C99-math-isfinite.patch
7faa279d64c9ec2e7abc7c0497c7e07e 0003-xulrunner-jemalloc-aslr.patch
-7cf18be3ada3eed5856fbab24219126d 0004-xulrunner-malloc_usable_size.patch
+d12e0636e1f9877ef2d1df45d5834c87 0004-xulrunner-malloc_usable_size.patch
96b40acd003a0a586e408bf09ae5af1d ff9-aslr-fix.patch"
diff --git a/testing/xulrunner/mozconfig b/testing/xulrunner/mozconfig
index 9401c84a1..2cbb45b7a 100644
--- a/testing/xulrunner/mozconfig
+++ b/testing/xulrunner/mozconfig
@@ -9,6 +9,7 @@ ac_add_options --with-system-zlib
ac_add_options --with-system-bz2
ac_add_options --with-system-libevent
ac_add_options --enable-system-hunspell
+ac_add_options --enable-system-sqlite
ac_add_options --enable-system-cairo
ac_add_options --with-pthreads
ac_add_options --enable-strip