summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2012-01-30 08:57:59 +0200
committerTimo Teräs <timo.teras@iki.fi>2012-01-30 08:59:16 +0200
commitb0621a4f0c34e7567f94e714cb80454fb2c1a2a2 (patch)
tree8d419003c57bc04bac6efdbe25cb676f7ee55897 /testing
parentdcfb205b30efdac8fdc620cc69e00c2d7e91faa7 (diff)
downloadaports-b0621a4f0c34e7567f94e714cb80454fb2c1a2a2.tar.bz2
aports-b0621a4f0c34e7567f94e714cb80454fb2c1a2a2.tar.xz
testing/libdvdnav: new aport
a library for sophisticated DVD navigation features http://dvdnav.mplayerhq.hu/
Diffstat (limited to 'testing')
-rw-r--r--testing/libdvdnav/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/libdvdnav/APKBUILD b/testing/libdvdnav/APKBUILD
new file mode 100644
index 000000000..e0a9e052a
--- /dev/null
+++ b/testing/libdvdnav/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=libdvdnav
+pkgver=4.2.0
+pkgrel=0
+pkgdesc="a library for sophisticated DVD navigation features"
+url="http://dvdnav.mplayerhq.hu/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="libdvdread-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://dvdnav.mplayerhq.hu/releases/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/libdvdnav-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure2 --prefix=/usr --disable-static --disable-debug --enable-shared || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="53be8903f9802e101929a3451203bbf6 libdvdnav-4.2.0.tar.bz2"