summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-19 09:19:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-19 09:19:09 +0000
commitb95e47c98a7fa1f9099ef1cc31fb829ef584f13a (patch)
tree93440a7194337f5535bd3945959384654cae0b3c /testing
parent26be3c6d5f986eee21cd4f7a94d7d0713ed24df6 (diff)
downloadaports-b95e47c98a7fa1f9099ef1cc31fb829ef584f13a.tar.bz2
aports-b95e47c98a7fa1f9099ef1cc31fb829ef584f13a.tar.xz
main/abuild: upgrade to 2.3
Diffstat (limited to 'testing')
-rw-r--r--testing/openobex/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/openobex/APKBUILD b/testing/openobex/APKBUILD
new file mode 100644
index 000000000..4c83330cd
--- /dev/null
+++ b/testing/openobex/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=openobex
+pkgver=1.5
+pkgrel=0
+pkgdesc="Implementation of the OBject EXchange (OBEX) protocol"
+url="http://dev.zuckschwerdt.org/openobex/"
+license="GPL LGPL"
+depends=
+makedepends="bluez-dev libusb-dev"
+subpackages="$pkgname-dev libopenobex"
+source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --enable-apps \
+ --enable-irda \
+ --enable-bluetooth \
+ --enable-usb \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+libopenobex() {
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libopenobex.so.* "$subpkgdir"/usr/lib/
+}
+
+md5sums="fce1b82eafb74bde54fe117372393ba8 openobex-1.5.tar.bz2"