summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-06-02 18:17:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-06-02 18:17:29 +0000
commitce58a1081b44f3f28f65372def5b43b86492ca4f (patch)
tree33ea30d88c051bf20a3de38513f9780ae8970128 /testing
parentb7d7e6463401eda3bd05e26c74b355e63345e564 (diff)
downloadaports-ce58a1081b44f3f28f65372def5b43b86492ca4f.tar.bz2
aports-ce58a1081b44f3f28f65372def5b43b86492ca4f.tar.xz
main/lua-dbi: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/lua-dbi/APKBUILD66
-rw-r--r--testing/lua-dbi/lua-dbi-postgresql.patch9
2 files changed, 0 insertions, 75 deletions
diff --git a/testing/lua-dbi/APKBUILD b/testing/lua-dbi/APKBUILD
deleted file mode 100644
index 4455308b4..000000000
--- a/testing/lua-dbi/APKBUILD
+++ /dev/null
@@ -1,66 +0,0 @@
-# Contributor: Leonardo Arena <rnarld@alpinelinux.org>
-# Maintainer:
-pkgname=lua-dbi
-_realname=luadbi
-pkgver=0.5
-pkgrel=1
-pkgdesc="A database interface library for Lua"
-url="http://code.google.com/p/luadbi"
-arch="all"
-license="GPL"
-depends=""
-makedepends="lua-dev mysql-dev postgresql-dev sqlite-dev"
-install=""
-subpackages="$pkgname-mysql $pkgname-postgresql $pkgname-sqlite"
-source="http://luadbi.googlecode.com/files/$_realname.$pkgver.tar.gz
- lua-dbi-postgresql.patch"
-
-_builddir="$srcdir"
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- # install -d "$pkgdir"/usr/lib/lua/5.1
- install -D -m755 "$srcdir"/DBI.lua "$pkgdir"/usr/share/lua/5.1/DBI.lua || return 1
- rm -f "$pkgdir"/usr/lib/*.la
-}
-
-_mv_backend() {
- install -d "$subpkgdir"/usr/lib/lua/5.1
- mv "$srcdir"/dbd${1}.so "$subpkgdir"/usr/lib/lua/5.1
-}
-
-sqlite() {
- pkgdesc="lua-dbi SQLite backend"
- depends="lua-dbi sqlite"
- _mv_backend sqlite3
-}
-
-mysql() {
- pkgdesc="lua-dbi MySQL backend"
- depends="lua-dbi mysql"
- _mv_backend mysql
-}
-
-postgresql() {
- pkgdesc="lua-dbi PostgreSQL backend"
- depends="lua-dbi postgresql"
- _mv_backend postgresql
-}
-
-md5sums="ede2b003aadddc151aac87050c3d926e luadbi.0.5.tar.gz
-67fa36ca81d2d7003be5a3f86d35c79c lua-dbi-postgresql.patch"
diff --git a/testing/lua-dbi/lua-dbi-postgresql.patch b/testing/lua-dbi/lua-dbi-postgresql.patch
deleted file mode 100644
index 2d2ba272d..000000000
--- a/testing/lua-dbi/lua-dbi-postgresql.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- a/dbd/postgresql/dbd_postgresql.h.old 2010-05-01 06:25:12.000000000 +0200
-+++ b/dbd/postgresql/dbd_postgresql.h 2011-04-19 16:59:53.364944209 +0200
-@@ -1,5 +1,5 @@
- #include <libpq-fe.h>
--#include <postgres_fe.h>
-+#include <server/postgres_fe.h>
- #include <dbd/common.h>
-
- /*