summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@me.com>2015-02-19 10:26:18 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2015-02-19 15:55:16 +0000
commite52e846d366b64644b75cfcab738f4937f465b42 (patch)
tree1a562e2a048cda3559811a4c59f49a9d1445c1f5 /testing
parentd619822e8905167b4a0b4e993d8c0e1c64aa445a (diff)
downloadaports-e52e846d366b64644b75cfcab738f4937f465b42.tar.bz2
aports-e52e846d366b64644b75cfcab738f4937f465b42.tar.xz
testing/encfs: fixed missing libstdc++ and added lib sub package
https://vgough.github.io/encfs/ EncFS provides an encrypted filesystem in user-space Signed-off-by: Leonardo Arena <rnalrd@alpinelinux.org>
Diffstat (limited to 'testing')
-rw-r--r--testing/encfs/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/testing/encfs/APKBUILD b/testing/encfs/APKBUILD
index fbcb30e03..250c9ccf2 100644
--- a/testing/encfs/APKBUILD
+++ b/testing/encfs/APKBUILD
@@ -10,11 +10,12 @@ arch="all"
license="GPL"
depends="fuse"
depends_dev=""
-makedepends="rlog-dev openssl-dev fuse-dev boost-dev
+makedepends="libstdc++ rlog-dev openssl-dev fuse-dev boost-dev
libtool gettext-dev autoconf automake"
install=""
-subpackages="$pkgname-doc"
+subpackages="$pkgname-libs $pkgname-doc"
source="$pkgname-$_ver.tar.gz::https://github.com/vgough/encfs/archive/v$_ver.tar.gz"
+options="libtool"
_builddir="$srcdir/${pkgname}-$_ver"
prepare() {
@@ -42,6 +43,7 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="${pkgdir}" install || return 1
+ libtool --finish "${pkgdir}"/usr/lib
find "$pkgdir" -name '*.la' -delete || return 1
}