summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndrew Hills <ahills@ednos.net>2015-05-28 21:34:00 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2015-06-03 13:35:35 +0000
commite85cd0b1a73ad53e49aae4113adf7c59aa68ac1b (patch)
tree4141ec910c6882f6412b1450ecf6d4cef4e10878 /testing
parentc6b57ecb7ff2826ffa6029ed262f49a7c96f3abb (diff)
downloadaports-e85cd0b1a73ad53e49aae4113adf7c59aa68ac1b.tar.bz2
aports-e85cd0b1a73ad53e49aae4113adf7c59aa68ac1b.tar.xz
testing/sl: new aport
https://github.com/mtoyoda/sl Steam locomotive: cure your bad habit of mistyping
Diffstat (limited to 'testing')
-rw-r--r--testing/sl/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/sl/APKBUILD b/testing/sl/APKBUILD
new file mode 100644
index 000000000..042357285
--- /dev/null
+++ b/testing/sl/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Andrew Hills <ahills@ednos.net>
+# Maintainer: Andrew Hills <ahills@ednos.net>
+pkgname=sl
+pkgver=5.02
+pkgrel=0
+pkgdesc="Cure your bad habit of mistyping"
+url="https://github.com/mtoyoda/sl"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="saveas-$url/archive/$pkgver.tar.gz/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ cd "$_builddir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm 755 sl "$pkgdir"/usr/bin/sl
+}
+
+md5sums="5d5fe203eb19598821647ba8db5dde6c sl-5.02.tar.gz"
+sha256sums="1e5996757f879c81f202a18ad8e982195cf51c41727d3fea4af01fdcbbb5563a sl-5.02.tar.gz"
+sha512sums="a4d18bc79d7e0eca7748b10226a6b2a85a7a01d636e4e9215bf524a7849bc5cb250034326e5a69f7423d79e40b92182fddc0e56e25df616edae06369c782cb26 sl-5.02.tar.gz"