summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMichael Zhou <zhoumichaely@gmail.com>2011-06-06 13:15:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-06 13:17:16 +0000
commite8f036a67c187e28e2bcd70e571bfde84a3e6476 (patch)
tree96465dd9efdf3c78bdd41f4b242f242135e2f15d /testing
parent2071eba1c4c9b097c8b5c367b7084292bf6c1dcd (diff)
downloadaports-e8f036a67c187e28e2bcd70e571bfde84a3e6476.tar.bz2
aports-e8f036a67c187e28e2bcd70e571bfde84a3e6476.tar.xz
new port: unionfs-fuse
Diffstat (limited to 'testing')
-rw-r--r--testing/unionfs-fuse/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/unionfs-fuse/APKBUILD b/testing/unionfs-fuse/APKBUILD
new file mode 100644
index 000000000..93e5c00bc
--- /dev/null
+++ b/testing/unionfs-fuse/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Michael Zhou <zhoumichaely@gmail.com>
+pkgname=unionfs-fuse
+pkgver=0.24
+pkgrel=0
+pkgdesc="Union Filesystem in Userspace"
+url="http://podgorny.cz/moin/UnionFsFuse"
+arch="all"
+license="GPL"
+depends=""
+makedepends="fuse-dev libiconv-dev"
+subpackages="${pkgname}-doc"
+source="http://podgorny.cz/unionfs-fuse/releases/${pkgname}-${pkgver}.tar.bz2"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/share/man/man8/
+ make DESTDIR="$pkgdir" PREFIX=/usr install || return 1
+}
+md5sums="ab00f252c55a9a7252fca13a53260bf5 unionfs-fuse-0.24.tar.bz2"