summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-18 09:14:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-18 09:14:15 +0000
commitef24e15982c9fee6a8c2985de8d602c8ca5ecc3e (patch)
tree547b702337b833000bdf6f025802366e00dc7d15 /testing
parent78b1da053750b7008573c12d6adca3f567e63caf (diff)
downloadaports-ef24e15982c9fee6a8c2985de8d602c8ca5ecc3e.tar.bz2
aports-ef24e15982c9fee6a8c2985de8d602c8ca5ecc3e.tar.xz
testing/bluez: new aport
Tools for the Bluetooth protocol stack http://www.bluez.org/
Diffstat (limited to 'testing')
-rw-r--r--testing/bluez/APKBUILD70
1 files changed, 70 insertions, 0 deletions
diff --git a/testing/bluez/APKBUILD b/testing/bluez/APKBUILD
new file mode 100644
index 000000000..32c9ec976
--- /dev/null
+++ b/testing/bluez/APKBUILD
@@ -0,0 +1,70 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=bluez
+pkgver=4.64
+pkgrel=0
+pkgdesc="Tools for the Bluetooth protocol stack"
+url="http://www.bluez.org/"
+license="GPL2"
+depends=
+makedepends="dbus-dev gstreamer-dev alsa-lib-dev libusb-dev libnl-dev"
+subpackages="$pkgname-dev $pkgname-doc libbluetooth $pkgname-alsa $pkgname-cups
+ $pkgname-netlink"
+source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/lib \
+ --mandir=/usr/share/man \
+ --enable-gstreamer \
+ --enable-alsa \
+ --enable-usb \
+ --enable-netlink \
+ --enable-tools \
+ --enable-bccmd \
+ --enable-hid2hci \
+ --enable-dfutool \
+ --enable-hidd \
+ --enable-pand \
+ --enable-dund \
+ --enable-cups \
+ --enable-configfiles \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+libbluetooth() {
+ pkgdesc="Libraries for Bluetooth protocol stack"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libbluetooth.so.* "$subpkgdir"/usr/lib/
+}
+
+alsa() {
+ pkgdesc="Bluez plugin for ALSA"
+ mkdir -p "$subpkgdir"/etc "$subpkgdir"/usr/lib
+ mv "$pkgdir"/etc/alsa* "$subpkgdir"/etc/
+ mv "$pkgdir"/usr/lib/alsa* "$subpkgdir"/usr/lib/
+}
+
+cups() {
+ pkgdesc="Bluez backend for CUPS"
+ mkdir -p "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/cups "$subpkgdir"/usr/lib/
+}
+
+netlink() {
+ pkgdesc="Bluez netlink plugin"
+ mkdir -p "$subpkgdir"/usr/lib/bluetooth/plugins
+ mv "$pkgdir"/usr/lib/bluetooth/plugins/netlink.so \
+ "$subpkgdir"/usr/lib/bluetooth/plugins
+}
+
+md5sums="d6e60bad937fe72b0bc77e327ee470b0 bluez-4.64.tar.bz2"