summaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-28 10:44:32 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-28 11:11:28 +0100
commit0457cebd9212d4986b225bbbce7d41df95a6bf2c (patch)
tree6a7a21fd8f5990be3d199ae2b628cd2b5873e3e8 /unmaintained
parentfe97e55c6069949d01a0fec50a6f93746b47214a (diff)
downloadaports-0457cebd9212d4986b225bbbce7d41df95a6bf2c.tar.bz2
aports-0457cebd9212d4986b225bbbce7d41df95a6bf2c.tar.xz
testing/apache-mod-backtrace: unmaintained
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/apache-mod-backtrace/APKBUILD38
-rw-r--r--unmaintained/apache-mod-backtrace/Makefile.in35
-rw-r--r--unmaintained/apache-mod-backtrace/configure.in46
3 files changed, 119 insertions, 0 deletions
diff --git a/unmaintained/apache-mod-backtrace/APKBUILD b/unmaintained/apache-mod-backtrace/APKBUILD
new file mode 100644
index 000000000..ee9884679
--- /dev/null
+++ b/unmaintained/apache-mod-backtrace/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Matt Smith <mcs@darkregion.net>
+# Maintainer: Matt Smith <mcs@darkregion.net>
+pkgname=apache-mod-backtrace
+pkgver=0
+pkgrel=2
+pkgdesc="A module which uses system functions to format a backtrace to show what code did the dirty deed."
+url="http://people.apache.org/~trawick/exception_hook.html"
+arch="all"
+license="ASL 2.0"
+depends="apache2"
+makedepends="apache2-dev apr-dev autoconf"
+install=""
+subpackages=""
+source="http://people.apache.org/~trawick/mod_backtrace.c
+ configure.in
+ Makefile.in"
+
+build() {
+ cd "$srcdir"
+ autoconf
+ ./configure
+ make DESTDIR="$pkgdir" || return 1
+}
+
+package() {
+ cd "$srcdir"
+ install -D -m755 "$srcdir"/.libs/mod_backtrace.so "$pkgdir"/usr/lib/apache2/mod_backtrace.so
+}
+
+md5sums="6535f86200e759722d5145a1f29ef966 mod_backtrace.c
+623409fd18dea63d6da509f2818491ef configure.in
+e796e84b98ad73f2420ad8ef6fc5c01b Makefile.in"
+sha256sums="285d38fb1ccb2824c1194e8951846d2660a64747c8b10a3f238e0d62beb6e87c mod_backtrace.c
+a679a358e0bffc448cc9250081a38ff10c15e045e2be8abdd5d97d2c87def9a8 configure.in
+a6856d67302d79a9d85881a49a0c9119e070b3ebedd4e8d814fa7e045e84c5d6 Makefile.in"
+sha512sums="ac8fff0c531fc46f6e6eba32b7eeaaf0fc3945927bca4e7c822f268d2132a1c3521ccc3b3593cb4ee6bc4d8c531c536fbc6c8c2c4a034213267d40f865774efc mod_backtrace.c
+bd21dc9c2b2c176478a47dc47bb6eaf1d2348dfbd2ffcb689605aa8f9270ebfd623a9dac1b30b27c3622bf025e74233a58096b9f21c8f31147e90009dd5031d3 configure.in
+2805d1ad2efb0c82a54aa53fd6fb999c5d332909af7a97da8cc47a36d539dfa8dbfca94165cd78dde85aef88db437516f65ed04078dcd1de2e71608a6790ed5c Makefile.in"
diff --git a/unmaintained/apache-mod-backtrace/Makefile.in b/unmaintained/apache-mod-backtrace/Makefile.in
new file mode 100644
index 000000000..1f05b116f
--- /dev/null
+++ b/unmaintained/apache-mod-backtrace/Makefile.in
@@ -0,0 +1,35 @@
+#
+# Makefile for mod_backtrace
+#
+# Based off of Makefile for mod_auth_ntlm_winbind by
+# Matt Smith <mcs@darkregion.net>, 2011/01/04
+#
+
+# Programs
+
+APXS = @APXS@
+APXS_FLAGS = @APXS_FLAGS@
+SODIR = @SODIR@
+APXSLIBDIR=$(DESTDIR)/$(shell $(APXS) -q LIBEXECDIR)
+
+# Build the dso
+MOD_BACKTRACE_SRC = mod_backtrace.c
+
+$(SODIR)mod_backtrace.so: $(MOD_BACKTRACE_SRC)
+ $(APXS) $(APXS_FLAGS) -Wc,-Wall -c -lubacktrace $(MOD_BACKTRACE_SRC)
+
+install: $(SODIR)mod_backtrace.so
+ $(APXS) $(APXS_FLAGS) -S LIBEXECDIR=$(APXSLIBDIR) -n backtrace -i $(SODIR)mod_backtrace.so
+
+# Clean targets
+clean:
+ @rm -f *~ $(MOD_BACKTRACE_SRC:.c=.{la,lo,o,slo})
+ @rm -rf $(SODIR)
+
+realclean: clean
+ @rm -f config.log
+
+distclean: realclean
+ @rm -f config.h Makefile \
+ config.status config.cache
+ @rm -rf autom4te.cache
diff --git a/unmaintained/apache-mod-backtrace/configure.in b/unmaintained/apache-mod-backtrace/configure.in
new file mode 100644
index 000000000..60de6023c
--- /dev/null
+++ b/unmaintained/apache-mod-backtrace/configure.in
@@ -0,0 +1,46 @@
+# Process this file with autoconf to produce a configure script.
+
+AC_INIT(mod_backtrace.c)
+
+# Basic stuff
+
+AC_PROG_CC
+AC_PROG_CPP
+AC_STDC_HEADERS
+
+# We use axps to compile source files, which may be in /usr/sbin
+AC_ARG_WITH(apxs,
+[ --with-apxs=PATH Specify path to apxs],
+[ APXS="$withval" ],
+[ AC_PATH_PROGS([APXS], [apxs2 apxs],, [$PATH:/usr/sbin]) ])
+
+AC_ARG_WITH(apache,
+[ --with-apache=PATH Specify path to apache executable],
+[ HTTPD="$withval" ],
+[ AC_PATH_PROG([HTTPD], [httpd], [/usr/sbin/httpd], [$PATH:/usr/sbin]) ])
+
+APACHE_VER=`${HTTPD} -v | grep version`
+if echo "$APACHE_VER" | grep -q "/2\."
+then
+ APXS_FLAGS=-DAPACHE2
+ SODIR=.libs/
+ echo "Building for Apache 2."
+else
+ echo "Building for Apache 1."
+fi
+
+# Check for some headers
+
+AC_CHECK_HEADERS(stdlib.h unistd.h sys/socket.h sys/time.h grp.h)
+AC_CHECK_HEADERS(nss_common.h nss.h)
+
+# Determine size of basic types
+
+AC_CHECK_SIZEOF(int,cross)
+AC_CHECK_SIZEOF(long,cross)
+AC_CHECK_SIZEOF(short,cross)
+
+# Create Makefile
+AC_SUBST(APXS_FLAGS)
+AC_SUBST(SODIR)
+AC_OUTPUT(Makefile)