summaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-28 14:00:54 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-28 13:15:44 +0000
commitada41186f8709f57199c71158590a15df4d4cbe9 (patch)
tree108a49e1722090093cd72e9e24793e4bf0020334 /unmaintained
parentb695337850c5afe7524e9d09a1b990fd5c5b8989 (diff)
downloadaports-ada41186f8709f57199c71158590a15df4d4cbe9.tar.bz2
aports-ada41186f8709f57199c71158590a15df4d4cbe9.tar.xz
testing/ifplugd: add missing patch
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/hessling-editor/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/hessling-editor/APKBUILD b/unmaintained/hessling-editor/APKBUILD
new file mode 100644
index 000000000..7153775ca
--- /dev/null
+++ b/unmaintained/hessling-editor/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor:
+# Maintainer:
+pkgname=hessling-editor
+_pkgname=THE
+pkgver=3.3_rc1
+_pkgver=3.3RC1
+pkgrel=1
+pkgdesc="Powerful text editor modelled on the XEDIT with the best features of Kedit."
+url="http://hessling-editor.sourceforge.net/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=
+makedepends="ncurses-dev regina-rexx"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$_pkgname-$_pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$_pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --with-rexx=regina --with-ncurses --prefix=/usr || return 1
+ make all || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="e46b63e533bc458f6f701983b7f2150b THE-3.3RC1.tar.gz"