summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/tvheadend/APKBUILD2
-rw-r--r--main/tvheadend/tvheadend.initd16
2 files changed, 11 insertions, 7 deletions
diff --git a/main/tvheadend/APKBUILD b/main/tvheadend/APKBUILD
index 2de602bf2..fe9417ab0 100644
--- a/main/tvheadend/APKBUILD
+++ b/main/tvheadend/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=tvheadend
pkgver=3.2.18
-pkgrel=0
+pkgrel=1
pkgdesc="TV Streaming server for linux"
url="http://www.lonelycoder.com/hts/tvheadend_overview.html"
arch="all"
diff --git a/main/tvheadend/tvheadend.initd b/main/tvheadend/tvheadend.initd
index c244dd63f..9b56313a8 100644
--- a/main/tvheadend/tvheadend.initd
+++ b/main/tvheadend/tvheadend.initd
@@ -1,19 +1,23 @@
#!/sbin/runscript
+
depend() {
need net
}
start() {
- ebegin "Starting tvheadend"
+ ebegin "Starting tvheadend"
start-stop-daemon --start \
- --user ${TVHUSER} \
- --exec ${TVHBIN} -- -C -f -c \
- ${TVHCONF}
+ --exec ${TVHBIN} -- \
+ -C -f -u ${TVHUSER} \
+ -c ${TVHCONF}
eend $?
}
stop() {
- ebegin "Stopping tvheadend"
- start-stop-daemon --stop --quiet --name tvheadend --signal 2
+ ebegin "Stopping tvheadend"
+ start-stop-daemon --stop --quiet \
+ --retry TERM/30/KILL/5 \
+ --pidfile /var/run/tvheadend.pid
eend $?
}
+