summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/gcc/APKBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 0e6464259..9275ad514 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -7,7 +7,7 @@ _specs_gcc_ver=4.4.3
_uclibc_abiver=0.9.32
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -147,7 +147,7 @@ prepare() {
build() {
local _dynamic_linker=
local _arch_configure=
- local _symvers="--disable-symvers"
+ local _symvers=
cd "$_gccdir"
export CFLAGS="-fno-stack-protector $CFLAGS"
[ -z "$CBUILD" ] && CBUILD="$CHOST"
@@ -162,13 +162,21 @@ build() {
;;
x86_64-*-gnu)
_dynamic_linker="--with-dynamic-linker=ld-linux-x86-64.so.2"
- _symvers=
;;
*-gnu)
_dynamic_linker="--with-dynamic-linker=ld-linux.so.2"
- _symvers=
;;
*) _dynamic_linker=
+ _symvers="--disable-symvers"
+ ;;
+ esac
+
+ # disable symvers for non-glibc (uclibc/musl)
+ # ifunc attributes detection is broke in configure script so force
+ # disable it for non-glibc. It is used heavily by Go lang.
+ case "$CHOST" in
+ *-gnu) ;;
+ *) export libat_cv_have_ifunc=no
;;
esac