summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/mosh/APKBUILD (renamed from testing/mosh/APKBUILD)28
-rw-r--r--main/mosh/disable-utf8-check.patch (renamed from testing/mosh/disable-utf8-check.patch)0
2 files changed, 24 insertions, 4 deletions
diff --git a/testing/mosh/APKBUILD b/main/mosh/APKBUILD
index 46e6d41f1..5da8587c3 100644
--- a/testing/mosh/APKBUILD
+++ b/main/mosh/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=mosh
pkgver=1.2.4
-pkgrel=2
+pkgrel=3
pkgdesc="Mobile shell (mosh) surviving disconnects with local echo and line editing"
url="http://mosh.mit.edu"
-arch="all"
+arch="noarch"
license="GPL3+"
-depends="perl-io-tty"
+depends="$pkgname-client $pkgname-server"
makedepends="ncurses-dev zlib-dev openssl-dev perl-dev perl-io-tty protobuf-dev"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-client $pkgname-server"
source="http://$pkgname.mit.edu/$pkgname-$pkgver.tar.gz
disable-utf8-check.patch"
@@ -38,6 +38,26 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
+server() {
+ arch="all"
+ replaces="mosh"
+ pkgdesc="Mosh server"
+ depends=
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/mosh-server \
+ "$subpkgdir"/usr/bin/ || return 1
+}
+
+client() {
+ arch="all"
+ replaces="mosh"
+ pkgdesc="Mosh client"
+ depends="openssh-client perl-io-tty"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/mosh-client \
+ "$subpkgdir"/usr/bin/ || return 1
+}
+
md5sums="c2d918f4d91fdc32546e2e089f9281b2 mosh-1.2.4.tar.gz
f9e6a14dc7a300d95625265ab5e847d7 disable-utf8-check.patch"
sha256sums="e74d0d323226046e402dd469a176075fc2013b69b0e67cea49762c957175df46 mosh-1.2.4.tar.gz
diff --git a/testing/mosh/disable-utf8-check.patch b/main/mosh/disable-utf8-check.patch
index 3d8716aa1..3d8716aa1 100644
--- a/testing/mosh/disable-utf8-check.patch
+++ b/main/mosh/disable-utf8-check.patch