summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/pcsc-lite/APKBUILD (renamed from testing/pcsc-lite/APKBUILD)28
-rw-r--r--main/pcsc-lite/pcsc-lite-1.8.11-nopolkit.patch35
-rw-r--r--main/pcsc-lite/pcsc-lite.pre-install3
-rw-r--r--main/pcsc-lite/pcscd.initd (renamed from testing/pcsc-lite/pcscd.initd)6
4 files changed, 58 insertions, 14 deletions
diff --git a/testing/pcsc-lite/APKBUILD b/main/pcsc-lite/APKBUILD
index dca274e24..aec600ed9 100644
--- a/testing/pcsc-lite/APKBUILD
+++ b/main/pcsc-lite/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=pcsc-lite
-pkgver=1.8.8
+pkgver=1.8.11
pkgrel=0
pkgdesc="Middleware to access a smart card using SCard API (PC/SC)"
url="http://pcsclite.alioth.debian.org/pcsclite.html"
@@ -9,11 +9,12 @@ arch="all"
license="Custom"
depends=""
depends_dev="udev-dev"
-makedepends="$depends_dev perl"
-install=""
+makedepends="$depends_dev perl automake autoconf libtool"
+install="pcsc-lite.pre-install"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="https://alioth.debian.org/frs/download.php/file/3862/pcsc-lite-${pkgver}.tar.bz2
- pcscd.initd"
+source="https://alioth.debian.org/frs/download.php/file/3991/pcsc-lite-1.8.11.tar.bz2
+ pcscd.initd
+ pcsc-lite-1.8.11-nopolkit.patch"
_builddir="$srcdir"/pcsc-lite-$pkgver
prepare() {
@@ -28,6 +29,7 @@ prepare() {
build() {
cd "$_builddir"
+ ./bootstrap
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
@@ -40,6 +42,7 @@ build() {
--without-systemdsystemunitdir \
--enable-ipcdir=/run/pcscd \
--enable-usbdropdir=/usr/lib/pcsc/drivers \
+ --disable-polkit \
|| return 1
make || return 1
}
@@ -60,9 +63,12 @@ libs() {
"$subpkgdir"/usr || return 1
}
-md5sums="069dc875a2ae2d85a2ebceac73252c0a pcsc-lite-1.8.8.tar.bz2
-1d891cc0401773e5487269df06b881c6 pcscd.initd"
-sha256sums="fe66354a7e738d3ef8b4e572c7e447b85894da9262381fbf004e8abcc12885e7 pcsc-lite-1.8.8.tar.bz2
-e605bd74a16a978144346265aca4c48f709cf7c3fc1043930cdf591cba4b8620 pcscd.initd"
-sha512sums="02b0ce81fb1f3a0358967825499ff3687bd7375ac6b0ff892f23c0980864046330a3db6b1296aa7a4baa135f94a8b85112518a2584de3b522bd2b8dc58894658 pcsc-lite-1.8.8.tar.bz2
-3b70cdd1b07d1a118a5b808f3d2ab3d129c16c388d54d19df82886c2a1de947be7eb1e0da100395445681e68402e74d7a4c60bd070061b4495edd0143e27e394 pcscd.initd"
+md5sums="73502ca4ba6526727f9f49c63d805408 pcsc-lite-1.8.11.tar.bz2
+6268a2247c0f3aa2998da1432e5a43d0 pcscd.initd
+04d6b0bd35bc7b95319d483222675335 pcsc-lite-1.8.11-nopolkit.patch"
+sha256sums="945041c94c53959ae5a767616a4ec5099fe67f549bfd344e8bd0cfe7a3c71ac6 pcsc-lite-1.8.11.tar.bz2
+4668c7b42d51c1b5dd05671d538fdb443603ee900542afeb0a817e9fcf42ef94 pcscd.initd
+f35db5c74576bb656130f0a0402cd67917a65fb63fb37b7fcddca5800e76ad9a pcsc-lite-1.8.11-nopolkit.patch"
+sha512sums="22f65f27f5b5cab04f6067f820c2564c3b42fcb3a54764416aa8676c9e19ccae1f0414f4e90d7ef1b91e27535bdfa31d73f5af4a9d994957d4ab369b0aadc5bd pcsc-lite-1.8.11.tar.bz2
+5b929ab607b3c897cb7d34e01af94f1481c3dc6c1c46f54ed04a35079c6f8fb082346263ba0efdd99e83f17bd6fd2726444d6ebca0f5f947d935b018448d86a5 pcscd.initd
+54e91069a6a0a87c02d986cf9b51096f7aac2f559cfd0603c32439a9ff0604b33d1d799790312fa876d3331ce88be2a0457c5f64219c5b5276263a6f2675e97f pcsc-lite-1.8.11-nopolkit.patch"
diff --git a/main/pcsc-lite/pcsc-lite-1.8.11-nopolkit.patch b/main/pcsc-lite/pcsc-lite-1.8.11-nopolkit.patch
new file mode 100644
index 000000000..8e6fbc9e6
--- /dev/null
+++ b/main/pcsc-lite/pcsc-lite-1.8.11-nopolkit.patch
@@ -0,0 +1,35 @@
+Index: pcsc-lite-1.8.11/configure.ac
+===================================================================
+--- pcsc-lite-1.8.11/configure.ac
++++ pcsc-lite-1.8.11/configure.ac
+@@ -284,16 +284,15 @@ fi
+ POLKIT_MINIMUM=0.111
+ AC_ARG_ENABLE(polkit,
+ AS_HELP_STRING([--enable-polkit],
+- [Build with polkit support]),
+- use_polkit=$withval, use_polkit=no)
+-if test "$use_polkit" != "no"; then
+- PKG_CHECK_MODULES(POLKIT, [polkit-gobject-1 >= $POLKIT_MINIMUM], [use_polkit=yes], [use_polkit=no])
+- if test "$use_polkit" != "no";then
++ [Build with polkit support]))
++if test "x$enable_polkit" != "xno"; then
++ PKG_CHECK_MODULES(POLKIT, [polkit-gobject-1 >= $POLKIT_MINIMUM], [enable_polkit=yes], [enable_polkit=no])
++ if test "$enable_polkit" != "no";then
+ AC_DEFINE([HAVE_POLKIT], 1, [Build polkit access control support])
+ polkit_policy_dir=$($PKG_CONFIG polkit-gobject-1 --variable=policydir)
+ AC_SUBST(POLICY_DIR, [$polkit_policy_dir])
+ else
+- use_polkit=no
++ enable_polkit=no
+ AC_MSG_ERROR([[
+ ***
+ *** polkit >= $POLKIT_MINIMUM was not found. Access control will be disabled.
+@@ -301,7 +300,7 @@ if test "$use_polkit" != "no"; then
+ *** ]])
+ fi
+ fi
+-AM_CONDITIONAL(ENABLE_POLKIT, test "$use_polkit" != "no")
++AM_CONDITIONAL(ENABLE_POLKIT, test "$enable_polkit" != "no")
+
+ # --with-systemdsystemunitdir=DIR
+ AC_ARG_WITH([systemdsystemunitdir],
diff --git a/main/pcsc-lite/pcsc-lite.pre-install b/main/pcsc-lite/pcsc-lite.pre-install
new file mode 100644
index 000000000..276309a42
--- /dev/null
+++ b/main/pcsc-lite/pcsc-lite.pre-install
@@ -0,0 +1,3 @@
+#!/bin/sh
+adduser -H -G pcscd -D -s /sbin/nologin pcscd 2>/dev/null
+exit 0
diff --git a/testing/pcsc-lite/pcscd.initd b/main/pcsc-lite/pcscd.initd
index db366062c..4208d21f8 100644
--- a/testing/pcsc-lite/pcscd.initd
+++ b/main/pcsc-lite/pcscd.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/files/pcscd-init.6,v 1.1 2013/01/16 20:49:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/files/pcscd-init.7,v 1.1 2014/02/14 23:11:54 flameeyes Exp $
name="PC/SC Daemon"
@@ -14,7 +14,7 @@ start_stop_daemon_args="--user pcscd:pcscd"
depend() {
need localmount
- after udev openct
+ after udev openct dbus
use logger
}