summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/ucarp/APKBUILD3
-rw-r--r--testing/ucarp/nocxx.patch15
2 files changed, 18 insertions, 0 deletions
diff --git a/testing/ucarp/APKBUILD b/testing/ucarp/APKBUILD
index ed35064f1..4deee45da 100644
--- a/testing/ucarp/APKBUILD
+++ b/testing/ucarp/APKBUILD
@@ -11,11 +11,13 @@ makedepends="libpcap-dev"
install=
subpackages=""
source="http://download.pureftpd.org/pub/ucarp/$pkgname-$pkgver.tar.gz
+ nocxx.patch
ucarp.initd
ucarp.confd"
build() {
cd "$srcdir/$pkgname-$pkgver"
+ patch configure < ../nocxx.patch || return 1
./configure --prefix=/usr \
--sysconfdir=/etc \
@@ -29,5 +31,6 @@ build() {
}
md5sums="ba585233e73f0dbce80427d04f431048 ucarp-1.5.tar.gz
+28513788ba4d556ccd538867dc6205ab nocxx.patch
e8f1e2fd144797524025343603dbe2b8 ucarp.initd
bf914f6ce4fe4fea33a45d4d5b2c1fff ucarp.confd"
diff --git a/testing/ucarp/nocxx.patch b/testing/ucarp/nocxx.patch
new file mode 100644
index 000000000..beb1ab900
--- /dev/null
+++ b/testing/ucarp/nocxx.patch
@@ -0,0 +1,15 @@
+--- a/configure 2004-12-07 21:34:23.205172545 +0000
++++ b/configure 2004-12-07 21:37:17.726654782 +0000
+@@ -5148,10 +5148,8 @@
+ :
+ else
+ { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
++See \`config.log' for more details." >&5;}
++ { echo "C++ sucks, ignoring ..." >&5; }; }
+ fi
+
+ ac_ext=cc