summaryrefslogtreecommitdiffstats
path: root/main/freeswitch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/freeswitch/APKBUILD')
-rw-r--r--main/freeswitch/APKBUILD64
1 files changed, 64 insertions, 0 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
new file mode 100644
index 000000000..4659f4f51
--- /dev/null
+++ b/main/freeswitch/APKBUILD
@@ -0,0 +1,64 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+pkgname=freeswitch
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="A communications platform written in C from the ground up"
+url="http://www.freeswitch.org"
+license="GPL"
+depends=""
+makedepends="curl-dev unixodbc-dev zlib-dev openssl-dev
+ autoconf automake libtool"
+install=
+subpackages="$pkgname-dev"
+source="http://files.freeswitch.org/freeswitch-$pkgver.tar.gz
+ modules.conf
+ freeswitch.confd
+ freeswitch.initd
+ freeswitch.post-install
+ freeswitch.pre-install
+ freeswitch.post-deinstall
+ "
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cp -f "$srcdir/modules.conf" modules.conf || return 1
+
+ # i think our max cmd len is 32768
+ # by specifying it here we save our selves from some CPU cycles
+ export lt_cv_sys_max_cmd_len=8192
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/freeswitch \
+ --with-modinstdir=/usr/lib/freeswitch \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+
+ # check how/when parallel builds are fixed here:
+ # http://jira.freeswitch.org/browse/FSBUILD-6
+
+ # build the libs and prerequisites in parallel first
+ make libs/apr/libapr-1.la \
+ libs/apr-util/libaprutil-1.la \
+ libs/speex/libspeex/libspeexdsp.la \
+ libs/sqlite/libsqlite3.la \
+ libs/pcre/libpcre.la \
+ libs/srtp/libsrtp.la \
+ src/include/switch_version.h
+
+ # then the rest should build in parallel too
+ make || return 1
+}
+package(){
+ cd "$srcdir/$pkgname-$pkgver"
+ make -j1 DESTDIR="$pkgdir" install
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="388effee587887a81fe7f411b7350590 freeswitch-1.0.6.tar.gz
+c05f2356be159e99b3845f5260a33599 modules.conf
+c608cca8ad773acebf201f581438c7e7 freeswitch.confd
+dd3a6535c54fc6ed8399d6bb57d88369 freeswitch.initd
+c0d7ad55063b1f62c9a2fcfa37b2fc0a freeswitch.post-install
+a34305ba1f8a8e7e6dbb9c678cc442b9 freeswitch.pre-install
+a7188703019a74fd7f128d165b3ecf42 freeswitch.post-deinstall"