summaryrefslogtreecommitdiffstats
path: root/main/lighttpd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/lighttpd/APKBUILD')
-rw-r--r--main/lighttpd/APKBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/main/lighttpd/APKBUILD b/main/lighttpd/APKBUILD
index 939bc9343..44125b0e9 100644
--- a/main/lighttpd/APKBUILD
+++ b/main/lighttpd/APKBUILD
@@ -2,7 +2,7 @@
pkgname=lighttpd
pkgver=1.4.26
_streamver=2.2.0
-pkgrel=0
+pkgrel=2
pkgdesc="a secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
license="custom"
@@ -21,12 +21,20 @@ source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.ta
mime-types.conf
mod_cgi.conf
mod_fastcgi.conf
+ lighttpd-version-from-git.patch
+ fix-handling-return-value-of-SSL_CTX_set_options.patch
"
subpackages="$pkgname-dev $pkgname-doc $pkgname-h264_streaming"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
+ # http://bugs.alpinelinux.org/issues/323
+ patch -p0 -i "$srcdir"/lighttpd-version-from-git.patch || return 1
+
+ # http://bugs.alpinelinux.org/issues/329
+ patch -p2 -i "$srcdir"/fix-handling-return-value-of-SSL_CTX_set_options.patch || return 1
+
# copy over the mod-h264-streaming mod
# http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Lighttpd-Version2#DownloadLighttpd1.4.191.4.20andother1.4.x
cp "$srcdir"/lighttpd-1.4.18/src/moov.* src/
@@ -111,4 +119,6 @@ ad091c9157134890499f26d170352c9f lighttpd.logrotate
df5b2360ea380d988bf16905ab214286 lighttpd.conf
fef397e7bcf1b741dea211a555e1803c mime-types.conf
9c1407e95f62ed22da66c4ef5f69c3b5 mod_cgi.conf
-f3363e39832f1b6678468b482d121afb mod_fastcgi.conf"
+f3363e39832f1b6678468b482d121afb mod_fastcgi.conf
+c2471f50eec2ce85da6dfaf8289725bc lighttpd-version-from-git.patch
+770baaa9a8dae51e25db29d3561d5b76 fix-handling-return-value-of-SSL_CTX_set_options.patch"