summaryrefslogtreecommitdiffstats
path: root/main/parted/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/parted/APKBUILD')
-rw-r--r--main/parted/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/main/parted/APKBUILD b/main/parted/APKBUILD
new file mode 100644
index 000000000..a606b7579
--- /dev/null
+++ b/main/parted/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=parted
+pkgver=1.8.8
+pkgrel=1
+pkgdesc="Utility to create, destroy, resize, check and copy partitions"
+url="http://www.gnu.org/software/parted/parted.html"
+license="GPL3"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends="pkgconfig e2fsprogs-dev readline-dev ncurses-dev"
+source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+ nocxx.patch"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ patch configure < ../nocxx.patch || return 1
+
+ ./configure --prefix=/usr \
+ --disable-debug \
+ --disable-nls \
+ --disable-Werror
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+md5sums="0d494591731082ec57cc18627728124a parted-1.8.8.tar.gz
+28513788ba4d556ccd538867dc6205ab nocxx.patch"