summaryrefslogtreecommitdiffstats
path: root/main/pllua/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/pllua/APKBUILD')
-rw-r--r--main/pllua/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/main/pllua/APKBUILD b/main/pllua/APKBUILD
new file mode 100644
index 000000000..913f99bbd
--- /dev/null
+++ b/main/pllua/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=pllua
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="Procedural language for PostgreSQL using Lua"
+url="http://pgfoundry.org/projects/pllua"
+arch="x86 x86_64"
+license="GPL"
+depends="postgresql"
+makedepends="postgresql-dev lua-dev ccache"
+install=
+subpackages=""
+source="http://pgfoundry.org/frs/download.php/1722/$pkgname-$pkgver.tar.gz
+ pllua-01-0.3.1-include.patch"
+
+# append extra dependencies to -dev subpackage
+# remove if not used.
+# depends_dev="somepackage-dev"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in "$srcdir"/*.patch; do
+ msg "Applying ${i}"
+ patch -p1 -i $i || return 1
+ done
+
+ make || return 1
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="e57385bdf2d533ac73cd02401795cea8 pllua-0.3.1.tar.gz
+a47387e64b7dba8d58237c7dad0e2d61 pllua-01-0.3.1-include.patch"