summaryrefslogtreecommitdiffstats
path: root/testing/numix-themes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/numix-themes/APKBUILD')
-rw-r--r--testing/numix-themes/APKBUILD71
1 files changed, 71 insertions, 0 deletions
diff --git a/testing/numix-themes/APKBUILD b/testing/numix-themes/APKBUILD
new file mode 100644
index 000000000..a5815baa3
--- /dev/null
+++ b/testing/numix-themes/APKBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=numix-themes
+pkgver=2.5.1
+pkgrel=0
+pkgdesc="A modern flat theme with a combination of light and dark elements, GTK 2 and 3"
+url="http://shimmerproject.org/project/Numix/"
+arch="noarch"
+license="GPLv3"
+makedepends="$depends_dev"
+subpackages="$pkgname-gtk2 $pkgname-gtk3 $pkgname-metacity $pkgname-xfwm4 $pkgname-xfce4-notifyd:_notify
+ $pkgname-openbox:_openbox"
+source="numix-$pkgver.tar.gz::https://github.com/shimmerproject/Numix/archive/v$pkgver.tar.gz
+ commits-to-070515-since-2.2.5.patch
+ "
+
+_builddir="$srcdir"/Numix-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ # Remove Unity theme
+ rm -f gtk-3.0/apps/unity.css
+ sed -i '/unity\.css/d' gtk-3.0/gtk.css
+ rm -rf unity
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/share/themes/Numix
+ cp -pr * "$pkgdir"/usr/share/themes/Numix
+}
+
+_mv() {
+ pkgdesc="$1"
+ install_if="$pkgname=$pkgver-r$pkgrel $2";
+ depends=
+ local _i
+ shift; shift
+ mkdir -p "$subpkgdir"/usr/share/themes/Numix
+ for _i; do
+ msg "moving $_i"
+ mv "$pkgdir"/usr/share/themes/Numix/$_i \
+ "$subpkgdir"/usr/share/themes/Numix || return 1
+ done
+}
+
+gtk2() {
+ _mv "Numix GTK2 themes" gtk2.0 gtk-2.0
+ depends="gtk-murrine-engine"
+}
+
+gtk3() { _mv "Numix GTK3 themes" gtk3.0 gtk-3.0; }
+metacity() { _mv "Numix Metacity themes" metacity metacity-1; }
+xfwm4() { _mv "Numix Xfce4 themes" xfwm4 xfwm4; }
+_notify() { _mv "Numix Xfce4-notifyd themes" xfce4-notifyd xfce-notify-4.0; }
+_openbox() { _mv "Numix openbox themes" openbox openbox-3; }
+
+md5sums="4468cb3f2fe0d01e823df7c310778787 numix-2.5.1.tar.gz
+274751ea1ef473c6233d045c403b3f19 commits-to-070515-since-2.2.5.patch"
+sha256sums="64b0c34c49633879c8b0b9b685da7b927501ab6db265db15fed04705c04f935b numix-2.5.1.tar.gz
+30bc14240299ef02e01c237dbe037fda5a835f4825a811b636df5671cc0c01bf commits-to-070515-since-2.2.5.patch"
+sha512sums="69741cc87bfa4aa54567014c1f4edf4c67cf76c2db5f15158a6473357ec557f8486c7961874c28dfdf6ae41c2253bf469d5d6301d9b235135a020068aecaa513 numix-2.5.1.tar.gz
+f5edca62767cb94f70c3d71a78b63bc5d399e3686eaadb9282e44dde6c6b81c52e94266b25f9e156e1c980f9f7cb01f6c670c0f5a4fe38605a1528e7bb7c716f commits-to-070515-since-2.2.5.patch"