summaryrefslogtreecommitdiffstats
path: root/testing/util-vserver/chmod.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/util-vserver/chmod.patch')
-rw-r--r--testing/util-vserver/chmod.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/testing/util-vserver/chmod.patch b/testing/util-vserver/chmod.patch
new file mode 100644
index 000000000..53861e893
--- /dev/null
+++ b/testing/util-vserver/chmod.patch
@@ -0,0 +1,12 @@
+diff -ru a/Makefile.am b/Makefile.am
+--- a/Makefile.am 2009-09-29 13:48:10.000000000 +0000
++++ b/Makefile.am 2009-09-29 13:50:00.000000000 +0000
+@@ -149,7 +149,7 @@
+ @mkdir -p $$(dirname '$@')
+ @echo "$(SED) -e '...' $*.pathsubst >$*"
+ @$(SED) -e '$(pathsubst_RULES)' '$<' >'$@.tmp'
+- @-chmod --reference='$<' '$@.tmp'
++ @-chmod $$(stat -c %a '$<') '$@.tmp'
+ @if cmp -s '$@.tmp' '$*'; then \
+ echo "... no changes, reusing old version"; \
+ rm -f '$@.tmp'; \