summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-09-18 06:47:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-18 06:47:11 +0000
commit093fac848d3e536f1b6be30b8542349aa7358b2d (patch)
tree51123ad16158f881c37591feb6cff0780ae8fe3f
parent9d4dd808a142a0d831236d42122bc270f0bdc644 (diff)
downloadaports-093fac848d3e536f1b6be30b8542349aa7358b2d.tar.bz2
aports-093fac848d3e536f1b6be30b8542349aa7358b2d.tar.xz
testing/lua5.2-sec-prosody: new aport
Temporary fork of lua-sec necessary for prosody to support certificate authentication https://prosody.im/doc/depends/luasec/prosody
-rw-r--r--testing/lua5.2-sec-prosody/APKBUILD55
-rw-r--r--testing/lua5.2-sec-prosody/Makefile.patch11
2 files changed, 66 insertions, 0 deletions
diff --git a/testing/lua5.2-sec-prosody/APKBUILD b/testing/lua5.2-sec-prosody/APKBUILD
new file mode 100644
index 000000000..ac0372f89
--- /dev/null
+++ b/testing/lua5.2-sec-prosody/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Borys Zhukov <borys@zhukov.im>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_luaver=5.2
+pkgname=lua$_luaver-sec-prosody
+_name=luasec-prosody
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="Temporary fork of lua-sec necessary for prosody to support certificate authentication"
+url="https://prosody.im/doc/depends/luasec/prosody"
+arch="all"
+license="MIT"
+depends="lua$_luaver-socket"
+makedepends="lua$_luaver-dev openssl-dev"
+install=
+subpackages="$pkgname-doc"
+source="
+ https://prosody.im/tmp/luasec-prosody-$pkgver.tar.gz
+ "
+
+_builddir="$srcdir"/$_name-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make linux \
+ CC="${CC:-gcc}" \
+ LD="${CC:-gcc}" \
+ MYCFLAGS="$CFLAGS" \
+ MYLDFLAGS="$LDFLAGS" \
+ INC_PATH="$(pkg-config lua$_luaver --cflags)" \
+ || return 1
+}
+
+package() {
+ _luasharedir=/usr/share/lua/$_luaver
+ _lualibdir=/usr/lib/lua/$_luaver
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/$_luasharedir "$pkgdir"/$_lualibdir
+ make LUAPATH="$pkgdir"/$_luasharedir \
+ LUACPATH="$pkgdir"/$_lualibdir \
+ install
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname
+ cp -r samples "$pkgdir"/usr/share/doc/$pkgname/
+}
+md5sums="fbe70f5b43419bec16afdfee2b21c34b luasec-prosody-0.5.1.tar.gz"
+sha256sums="2fd34cf9c59a6491937c98ba33921d4fc418b160c0c89545f7bae4f246280ad4 luasec-prosody-0.5.1.tar.gz"
+sha512sums="eadae7f59e957ebc8df074c8e43b181380393e8dd2042bbd098576bf2d7710aa0abb4ccc87eb1b52d28e0473cc52626be6e06eabdec8821deca1cda82ad7cfe7 luasec-prosody-0.5.1.tar.gz"
diff --git a/testing/lua5.2-sec-prosody/Makefile.patch b/testing/lua5.2-sec-prosody/Makefile.patch
new file mode 100644
index 000000000..958c24a1b
--- /dev/null
+++ b/testing/lua5.2-sec-prosody/Makefile.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.orig
++++ b/src/Makefile
+@@ -22,7 +22,7 @@
+
+ INSTALL ?= install
+ CC ?= cc
+-LD ?= $(MYENV) cc
++LD = $(MYENV) cc
+ CFLAGS += $(MYCFLAGS)
+ LDFLAGS += $(MYLDFLAGS)
+ DESTDIR ?= /