summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2012-06-07 13:52:49 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2012-06-07 13:53:00 +0000
commit1da792ee04c8f35d0a5e78bc5664eb2df86a833a (patch)
treefaabdcd4af688b5b20e4aeed2857f28a324a9a97
parent3f2d35d1f7045a0086135381b56461fba58ba483 (diff)
downloadaports-1da792ee04c8f35d0a5e78bc5664eb2df86a833a.tar.bz2
aports-1da792ee04c8f35d0a5e78bc5664eb2df86a833a.tar.xz
testing/py-rtslib: add spec files for managing fabrics
-rw-r--r--testing/py-rtslib/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/testing/py-rtslib/APKBUILD b/testing/py-rtslib/APKBUILD
index 2370ba5cb..98ffa9058 100644
--- a/testing/py-rtslib/APKBUILD
+++ b/testing/py-rtslib/APKBUILD
@@ -5,7 +5,7 @@ _realname=rtslib
pkgver=2.1_p14
_ver=${pkgver/_rc/rc}
_ver=${_ver/_p/.fb}
-pkgrel=0
+pkgrel=1
pkgdesc="Python library that provides an object API to RisingTide Systems generic SCSI Target"
url="https://github.com/agrover/rtslib-fb"
arch="noarch"
@@ -56,6 +56,11 @@ build() {
package() {
cd "$_builddir"
python setup.py install --root="$pkgdir"
+ install -D -m644 specs/ib_srpt.spec $pkgdir/var/lib/target/fabric/ib_srpt.spec
+ install -D -m644 specs/iscsi.spec $pkgdir/var/lib/target/fabric/iscsi.spec
+ install -D -m644 specs/loopback.spec $pkgdir/var/lib/target/fabric/loopback.spec
+ install -D -m644 specs/qla2xxx.spec $pkgdir/var/lib/target/fabric/qla2xxx.spec
+ install -D -m644 specs/tcm_fc.spec $pkgdir/var/lib/target/fabric/tcm_fc.spec
}
md5sums="95881fd736567ccd911fbee7cc94a5ea rtslib-2.1.fb14.tar.gz"